summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD53
-rw-r--r--pulseaudio-module-xrdp.install9
-rw-r--r--xrdp-script.conf2
5 files changed, 50 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4f296fed6e6..99dad257cf63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = pulseaudio-module-xrdp
pkgdesc = PulseAudio modules for xrdp
- pkgver = 0.3
+ pkgver = 0.7
pkgrel = 1
url = https://github.com/neutrinolabs/pulseaudio-module-xrdp
+ install = pulseaudio-module-xrdp.install
arch = i686
arch = x86_64
- license = Apache
- makedepends = git
+ license = LGPL
+ makedepends = meson
+ makedepends = check
+ makedepends = doxygen
+ makedepends = perl-xml-parser
depends = pulseaudio
depends = xrdp
- source = pulseaudio-module-xrdp-0.3.tar.gz::https://github.com/neutrinolabs/pulseaudio-module-xrdp/archive/v0.3.tar.gz
- source = git+https://github.com/pulseaudio/pulseaudio.git
- source = xrdp-script.conf
- sha256sums = 11ebe426a93b3a22eeffe460ec643cabe33061757b6b2db5fa8807b2788e1e30
- sha256sums = SKIP
- sha256sums = 4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f
+ source = https://github.com/neutrinolabs/pulseaudio-module-xrdp/archive/refs/tags/v0.7.tar.gz
+ source = https://freedesktop.org/software/pulseaudio/releases/pulseaudio-16.1.tar.xz
+ sha256sums = be101538ebe891bd4ae9d533559b99cf07abf0bbce399f50f2d248f35c160a9d
+ sha256sums = 8eef32ce91d47979f95fd9a935e738cd7eb7463430dabc72863251751e504ae4
pkgname = pulseaudio-module-xrdp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bb24d62c7d0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!pulseaudio-module-xrdp.install
diff --git a/PKGBUILD b/PKGBUILD
index f33ef51c97f6..2b3ad64377a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
-# Maintainer: kballen <ken@kballentine.net>
+# Maintainer: Jat <chat@jat.email>
-pkgname=pulseaudio-module-xrdp
-pkgver=0.3
-pkgrel=1
-pkgdesc="PulseAudio modules for xrdp"
+pkgname='pulseaudio-module-xrdp'
+pkgver='0.7'
+pkgrel='1'
+pkgdesc='PulseAudio modules for xrdp'
arch=('i686' 'x86_64')
url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
-license=('Apache')
+license=('LGPL')
depends=('pulseaudio' 'xrdp')
-makedepends=('git')
+makedepends=('meson' 'check' 'doxygen' 'perl-xml-parser')
+install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz"
- "git+https://github.com/pulseaudio/pulseaudio.git"
- "xrdp-script.conf")
-sha256sums=('11ebe426a93b3a22eeffe460ec643cabe33061757b6b2db5fa8807b2788e1e30'
- 'SKIP'
- '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+_pulseaudio_ver="$(pulseaudio --version | awk '{print $NF}')"
+: "${_pulseaudio_ver:=16.1}"
+
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz")
+sha256sums=('be101538ebe891bd4ae9d533559b99cf07abf0bbce399f50f2d248f35c160a9d'
+ "$(curl -fs "${source[1]}.sha256sum" | awk '{print $1}')")
prepare() {
- cd "$srcdir/pulseaudio"
- git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
- NOCONFIGURE=1 ./bootstrap.sh
- ./configure
+ cd "${srcdir}/pulseaudio-${_pulseaudio_ver}"
+
+ meson build
}
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i '\#-I $(PULSE_DIR)/src#a -I $(PULSE_DIR)/build \\' src/Makefile.am
+
./bootstrap
- ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ ./configure "PULSE_DIR=${srcdir}/pulseaudio-${_pulseaudio_ver}"
make
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
- # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
- # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
- # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
- # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
- # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
- # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
- install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+ make DESTDIR="$pkgdir" install
}
diff --git a/pulseaudio-module-xrdp.install b/pulseaudio-module-xrdp.install
new file mode 100644
index 000000000000..5de9a9a9a65a
--- /dev/null
+++ b/pulseaudio-module-xrdp.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo -e '\033[0;31mRemember to pass the environment' \
+ '"PULSE_SCRIPT=/etc/xrdp/pulse/default.pa" to pulseaudio' \
+ 'to make this module work.\033[0m'
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/xrdp-script.conf b/xrdp-script.conf
deleted file mode 100644
index beb893ab169f..000000000000
--- a/xrdp-script.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-[Service]
-Environment=PULSE_SCRIPT=/etc/xrdp/pulse/default.pa