summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
-rw-r--r--punes-git.install19
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..448cc44a3b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Thu Oct 8 07:02:23 UTC 2015
+pkgbase = punes-git
+ pkgdesc = Nintendo Entertaiment System emulator
+ pkgver = r701.8d6b4a3
+ pkgrel = 1
+ url = http://forums.nesdev.com/viewtopic.php?t=6928
+ install = punes-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = autoconf-archive
+ depends = sdl
+ depends = qt5-base
+ depends = alsa-lib
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ provides = punes
+ conflicts = punes
+ source = git+https://github.com/punesemu/puNES.git
+ md5sums = SKIP
+
+pkgname = punes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62a30ab35137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Vaporeon <vaporeon@tfwno.gf>
+pkgname=punes-git
+pkgver=r701.8d6b4a3
+pkgrel=1
+pkgdesc="Nintendo Entertaiment System emulator"
+arch=('i686' 'x86_64')
+url="http://forums.nesdev.com/viewtopic.php?t=6928"
+license=('GPL2')
+depends=('sdl' 'qt5-base' 'alsa-lib' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('autoconf-archive')
+conflicts=('punes')
+provides=('punes')
+install=$pkgname.install
+source=("git+https://github.com/punesemu/puNES.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd puNES
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/puNES"
+ ./autogen.sh
+ ./configure --enable-qt5 --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/puNES"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/punes-git.install b/punes-git.install
new file mode 100644
index 000000000000..716c0a0d4694
--- /dev/null
+++ b/punes-git.install
@@ -0,0 +1,19 @@
+post_install() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}