summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 14 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52e4ff15ed82..af8c793b0caa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = purc
pkgdesc = The prime HVML interpreter for C Language.
- pkgver = 0.8.1
- pkgrel = 5
+ pkgver = 0.9.0
+ pkgrel = 1
url = https://github.com/HVML/PurC
arch = any
groups = hvml
@@ -22,16 +22,14 @@ pkgbase = purc
depends = glib2
depends = bison
depends = flex
- optdepends = domruler: DOM Ruler is a library to maintain a DOM tree, lay out and stylize the DOM elements by using CSS.
- optdepends = purc-fetcher: The remote data fetcher for PurC.
optdepends = purc-midnight-commander: A generic HVML renderer in text mode for development and debugging.
optdepends = webkit2gtk-hvml: Web content engine for GTK (HVML)
optdepends = xguipro: xGUI (the X Graphics User Interface) Pro is a modern, cross-platform, and advanced HVML renderer which is based on tailored WebKit.
provides = purc
provides = PurC
- conflicts = purc-git
+ conflicts = purc
options = !strip
- source = purc-0.8.1.tar.gz::https://github.com/HVML/PurC/archive/refs/tags/ver-0.8.1.tar.gz
- sha256sums = 387fc10560eed813cd92b36a224f17a7fa94c2aa20264f7e75c9c471505071d5
+ source = purc-0.9.0.tar.gz::https://github.com/HVML/PurC/archive/refs/tags/ver-0.9.0.tar.gz
+ sha256sums = 4fc77860b060a8d1ac54eac09e4c92e95e527e85308a2ff736c892c9d5e5b72a
pkgname = purc
diff --git a/PKGBUILD b/PKGBUILD
index 619c92d95945..4ae98f847b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,31 @@
# Maintainer: taotieren <admin@taotieren.com>
+pkgbase=purc
pkgname=purc
-pkgver=0.8.1
-pkgrel=5
+pkgver=0.9.0
+pkgrel=1
pkgdesc="The prime HVML interpreter for C Language."
arch=('any')
url="https://github.com/HVML/PurC"
license=('LGPL-3.0')
groups=('hvml')
provides=(${pkgname} 'PurC')
-conflicts=(${pkgname}-git)
-#replaces=(${pkgname})
-depends=('glib2' 'bison' 'flex')
-makedepends=('cmake' 'ninja' 'ccache' 'gcc' 'python' 'libxml2' 'ruby' 'curl' 'openssl' 'sqlite' 'pkgconf' 'zlib' 'icu')
-optdepends=('domruler: DOM Ruler is a library to maintain a DOM tree, lay out and stylize the DOM elements by using CSS.'
- 'purc-fetcher: The remote data fetcher for PurC.'
- 'purc-midnight-commander: A generic HVML renderer in text mode for development and debugging.'
+conflicts=(${pkgname})
+replaces=()
+depends=(glib2 bison flex)
+makedepends=(cmake ninja ccache gcc python libxml2 ruby curl openssl sqlite pkgconf zlib icu)
+optdepends=('purc-midnight-commander: A generic HVML renderer in text mode for development and debugging.'
'webkit2gtk-hvml: Web content engine for GTK (HVML)'
'xguipro: xGUI (the X Graphics User Interface) Pro is a modern, cross-platform, and advanced HVML renderer which is based on tailored WebKit.')
backup=()
options=('!strip')
#install=${pkgname}.install
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/ver-${pkgver}.tar.gz")
-sha256sums=('387fc10560eed813cd92b36a224f17a7fa94c2aa20264f7e75c9c471505071d5')
+sha256sums=('4fc77860b060a8d1ac54eac09e4c92e95e527e85308a2ff736c892c9d5e5b72a')
build() {
cd "${srcdir}/PurC-ver-${pkgver}/"
-# CMake build
-# cmake -DCMAKE_BUILD_TYPE=Release \
-# -DPORT=Linux \
-# -DENABLE_API_TESTS=OFF \
-# -DCMAKE_INSTALL_PREFIX=/usr \
-# -DCMAKE_INSTALL_LIBDIR=lib \
-# -DCMAKE_INSTALL_LIBEXECDIR=lib \
-# -B build
-
-# cmake --build build
-
# Ninja build
cmake -DCMAKE_BUILD_TYPE=Release \
-DPORT=Linux \
@@ -52,9 +40,6 @@ build() {
}
package() {
-# make install
-# make -C "${srcdir}"/PurC-ver-${pkgver}/build install DESTDIR="${pkgdir}"
-
# ninja install
DESTDIR="${pkgdir}" ninja -C "${srcdir}"/PurC-ver-${pkgver}/build install
}