summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e6ce78924d3..f4740a260a2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = puush-qt
pkgdesc = GUI frontend for puush which will create a system tray icon.
- pkgver = 0.1
- pkgrel = 4
+ pkgver = 0.2
+ pkgrel = 1
url = https://github.com/jplsek/puush-qt
arch = i686
arch = x86_64
license = BSD
makedepends = git
depends = scrot
- depends = curl
depends = qt5-base
source = git+https://github.com/jplsek/puush-qt.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2f7a59551dbf..4e765c5d2500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
-pkgver=0.1
-pkgrel=4
+pkgver=0.2
+pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
source=('git+https://github.com/jplsek/puush-qt.git')
md5sums=('SKIP')
makedepends=('git')
-depends=('scrot' 'curl' 'qt5-base')
+depends=('scrot' 'qt5-base')
prepare() {
mkdir $pkgname/build
}
build() {
- cd $pkgname/build
- qmake PREFIX=/usr ../src/puush-qt.pro
+ cd $pkgname
+ git submodule init
+ git submodule update
+ cd build
+ qmake PREFIX=/usr ../puush-qt.pro
make
}