summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD56
-rwxr-xr-xrelease.sh2
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..253e55c1c455
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pvr-tex-tool-bin
+ pkgdesc = A comprehensive texture processing and compression tool with support for PVR textures.
+ pkgver = 2020.2
+ pkgrel = 1
+ url = https://www.imaginationtech.com/developers/powervr-sdk-tools/pvrtextool/
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = install.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-2020_R2.run-x64
+ source = LICENSE.html::https://www.imaginationtech.com/developers/powervr-sdk-tools/powervr-sdk-software-eula/
+ sha256sums = 5f6bea49943e52d2f59541efca0bce8c1f841f9a5baf1a193c94cd0e1fcb4a31
+ sha256sums = 251a7012447f80a9cc1459028e12fb09794a5d003482e0d7dd3580a52ab5c686
+
+pkgname = pvr-tex-tool-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..35a55c28d28c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+install.run
+LICENSE.html
+pkg
+src
+*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1fc1799824b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Nathan Robinson <nrobinson2000 at me dot com>
+
+pkgname=pvr-tex-tool-bin
+pkgver=2020.2
+_versionstr='2020_R2'
+pkgrel=1
+
+pkgdesc="A comprehensive texture processing and compression tool with support for PVR textures."
+url="https://www.imaginationtech.com/developers/powervr-sdk-tools/pvrtextool/"
+
+arch=('x86_64')
+options=('!strip')
+license=('custom')
+
+source=("install.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-${_versionstr}.run-x64"
+"LICENSE.html::https://www.imaginationtech.com/developers/powervr-sdk-tools/powervr-sdk-software-eula/")
+
+sha256sums=('5f6bea49943e52d2f59541efca0bce8c1f841f9a5baf1a193c94cd0e1fcb4a31'
+'251a7012447f80a9cc1459028e12fb09794a5d003482e0d7dd3580a52ab5c686')
+
+# TODO: Figure out dependencies...
+# depends=()
+
+package() {
+_srcname=PVRTexTool
+
+# Run installer
+chmod +x "${srcdir}/install.run"
+"${srcdir}/install.run" --prefix "${srcdir}" --mode unattended
+
+# Install license
+install -Dm644 LICENSE.html "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
+
+# Install documentation
+mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+cp -r ${srcdir}/${_srcname}/* "${pkgdir}/usr/share/doc/${pkgname}"
+
+# Install library
+mkdir -p "${pkgdir}/usr/include"
+mkdir -p "${pkgdir}/usr/lib"
+cp ${srcdir}/${_srcname}/Library/Include/* "${pkgdir}/usr/include"
+cp ${srcdir}/${_srcname}/Library/Linux_x86_64/* "${pkgdir}/usr/lib"
+
+# Install CLI binaries
+install -D "${srcdir}/${_srcname}/CLI/Linux_x86_64/compare" "${pkgdir}/usr/bin/pvr-compare"
+install -D "${srcdir}/${_srcname}/CLI/Linux_x86_64/PVRTexToolCLI" "${pkgdir}/usr/bin/pvr-tex-tool"
+
+# Install GUI application
+mkdir -p "${pkgdir}/usr/share/${pkgname}"
+cp -r ${srcdir}/${_srcname}/GUI/Linux_x86_64/* "${pkgdir}/usr/share/${pkgname}"
+ln -s "${pkgdir}/usr/share/${pkgname}/PVRTexToolGUI" "${pkgdir}/usr/bin/pvr-tex-tool-gui"
+
+# Delete .run file (only pacman should be allowed to perform updates)
+rm "${srcdir}/${_srcname}/GUI/Linux_x86_64/autoupdate-linux-x64.run"
+
+}
diff --git a/release.sh b/release.sh
new file mode 100755
index 000000000000..a84faefa66e7
--- /dev/null
+++ b/release.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+makepkg --printsrcinfo > .SRCINFO \ No newline at end of file