summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ed372b3f1b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pwninit
+ pkgdesc = pwninit - automate starting binary exploit challenges
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/io12/pwninit
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ source = https://github.com/io12/pwninit/archive/0.1.0.tar.gz
+ md5sums = SKIP
+
+pkgname = pwninit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9b509729e96
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.gz
+*.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f246f846349
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Benjamin Levy <blevy@protonmail.com>
+pkgname=pwninit
+pkgver=0.1.0
+pkgrel=1
+makedepends=('rust' 'cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="pwninit - automate starting binary exploit challenges"
+license=('MIT')
+url="https://github.com/io12/pwninit"
+source=("https://github.com/io12/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo build --release --locked
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo test --release --locked
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+}