summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--pwsafe-XChangeProperty.patch20
3 files changed, 10 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbfb11dce227..487e6de7b053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Jan 11 20:56:33 UTC 2018
pkgbase = pwsafe
pkgdesc = A commandline program for managing encrypted password databases
- pkgver = 20170908
+ pkgver = r5.3e23fa2
pkgrel = 1
url = https://github.com/nsd20463/pwsafe
arch = x86_64
@@ -10,10 +8,7 @@ pkgbase = pwsafe
makedepends = git
depends = openssl
depends = libxmu
- source = git://github.com/nsd20463/pwsafe.git#commit=c3cc2ec031812ab33f0dab72a8d8b336ca486de0
- source = pwsafe-XChangeProperty.patch
+ source = git+https://github.com/nsd20463/pwsafe
md5sums = SKIP
- md5sums = cff6aee2e43f5fbe82e8cd7ccfefb099
pkgname = pwsafe
-
diff --git a/PKGBUILD b/PKGBUILD
index 5347d2eab213..2d4786881bb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
# Maintainer: Vesa Kaihlavirta <vegai@iki.fi>
pkgname=pwsafe
-pkgver=20170908
-_commit=c3cc2ec031812ab33f0dab72a8d8b336ca486de0
+pkgver=r5.3e23fa2
pkgrel=1
pkgdesc="A commandline program for managing encrypted password databases"
arch=('x86_64')
@@ -12,15 +11,16 @@ url="https://github.com/nsd20463/pwsafe"
license=('GPL')
depends=('openssl' 'libxmu')
makedepends=('git')
-source=("git://github.com/nsd20463/pwsafe.git#commit=${_commit}"
- pwsafe-XChangeProperty.patch)
-md5sums=('SKIP'
- 'cff6aee2e43f5fbe82e8cd7ccfefb099')
+source=(git+https://github.com/nsd20463/pwsafe)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
cd "$srcdir"/${pkgname}
- # Patch from fedora, fixes FS#28339
- patch -Np0 -i ../pwsafe-XChangeProperty.patch
}
build() {
diff --git a/pwsafe-XChangeProperty.patch b/pwsafe-XChangeProperty.patch
deleted file mode 100644
index 6758a573dc62..000000000000
--- a/pwsafe-XChangeProperty.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: pwsafe.cpp
-===================================================================
-RCS file: /cvsroot/pwsafe/pwsafe/pwsafe.cpp,v
-retrieving revision 1.57
-diff -u -r1.57 pwsafe.cpp
---- pwsafe.cpp 12 Aug 2007 12:33:06 -0000 1.57
-+++ pwsafe.cpp 5 Jan 2011 22:16:43 -0000
-@@ -1820,10 +1820,10 @@
- if (xev.xselectionrequest.target == XA_TARGETS(xdisplay)) {
- // tell them what we can supply
- const Atom targets[] = { XA_TARGETS(xdisplay), XA_TIMESTAMP(xdisplay), XA_TEXT(xdisplay), XA_STRING };
-- XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_TARGETS(xdisplay), 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&targets), sizeof(targets)/sizeof(targets[0]));
-+ XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_ATOM, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&targets), sizeof(targets)/sizeof(targets[0]));
- }
- else if (xev.xselectionrequest.target == XA_TIMESTAMP(xdisplay)) {
-- XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_TIMESTAMP(xdisplay), 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&timestamp), 1);
-+ XChangeProperty(xdisplay, xev.xselectionrequest.requestor, prop, XA_INTEGER, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&timestamp), 1);
- }
- else if (xev.xselectionrequest.target == XA_TEXT(xdisplay) ||
- xev.xselectionrequest.target == XA_STRING) {