summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
2 files changed, 32 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27b0d5b3b91b..ed1b1639eb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.8.4.r8.g06fa0ea
+ pkgver = 0.10.6.r11.gc8d9eeb
pkgrel = 1
- url = https://git.archlinux.org/pyalpm.git/
+ url = https://gitlab.archlinux.org/archlinux/pyalpm
arch = x86_64
- license = GPL3
- checkdepends = python-nose
+ license = GPL-3.0-only
+ checkdepends = python-pytest
+ checkdepends = python-pytest-pacman
makedepends = git
- depends = python>=3.6
- depends = pacman>=5
- provides = pyalpm=0.8.4.r8.g06fa0ea
+ makedepends = python-setuptools
+ makedepends = python-pkgconfig
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python
+ depends = pacman
+ provides = pyalpm
conflicts = pyalpm
- source = git+https://git.archlinux.org/pyalpm.git
+ source = git+https://gitlab.archlinux.org/archlinux/pyalpm.git
sha256sums = SKIP
pkgname = pyalpm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d88d35f08eeb..a0f230ecf40b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: a821
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: bartus
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
# Contributor: Dave Reisner <d@falconindy.com>
-_pkgname=pyalpm
-pkgname=$_pkgname-git
-pkgver=0.8.4.r8.g06fa0ea
+pkgname=pyalpm-git
+_pkgname=${pkgname%-git}
+pkgver=0.10.6.r11.gc8d9eeb
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('x86_64')
-url="https://git.archlinux.org/pyalpm.git/"
-license=('GPL3')
-depends=('python>=3.6' 'pacman>=5')
-makedepends=('git')
-checkdepends=('python-nose')
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-source=('git+https://git.archlinux.org/pyalpm.git')
+url="https://gitlab.archlinux.org/archlinux/pyalpm"
+license=('GPL-3.0-only')
+depends=('python' 'pacman')
+makedepends=('git' 'python-setuptools' 'python-pkgconfig' 'python-wheel' 'python-build' 'python-installer')
+checkdepends=('python-pytest' 'python-pytest-pacman')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -26,18 +29,15 @@ pkgver() {
build() {
cd $_pkgname
-
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd $_pkgname
-
- PYTHONPATH="$(ls -d build/lib.linux-$CARCH-*)" nosetests -v tests
+ PYTHONPATH="$(ls -d build/lib.linux-$CARCH-*)" pytest -v test
}
package() {
cd $_pkgname
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}