summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fix-build-for-Python-3.5.patch51
-rw-r--r--PKGBUILD22
3 files changed, 10 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f4222c4cded..67b32dfa1beb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Jan 31 21:24:37 UTC 2016
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.8.r0.g1b5abcf
+ pkgver = 0.8.1.r0.gda8de1a
pkgrel = 1
- url = http://projects.archlinux.org/users/remy/pyalpm.git/
+ url = http://projects.archlinux.org/pyalpm.git/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- depends = python>=3.2
+ depends = python>=3.6
depends = pacman>=5
- provides = pyalpm=0.8.r0.g1b5abcf
+ provides = pyalpm=0.8.1.r0.gda8de1a
conflicts = pyalpm
- source = git+https://projects.archlinux.org/git/users/remy/pyalpm.git
- source = 0001-Fix-build-for-Python-3.5.patch
+ source = git+https://projects.archlinux.org/git/pyalpm.git
md5sums = SKIP
- md5sums = d5481d4f9920860518277a78857c25e8
pkgname = pyalpm-git
diff --git a/0001-Fix-build-for-Python-3.5.patch b/0001-Fix-build-for-Python-3.5.patch
deleted file mode 100644
index 061cbff0f1a0..000000000000
--- a/0001-Fix-build-for-Python-3.5.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 327f1055e62b4905d6cfa0e2997e35eb358a5c14 Mon Sep 17 00:00:00 2001
-From: Yen Chi Hsuan <yan12125@gmail.com>
-Date: Tue, 6 Oct 2015 12:47:18 +0800
-Subject: [pyalpm][PATCH] Fix build for Python 3.5
-
-Signed-off-by: Yen Chi Hsuan <yan12125@gmail.com>
----
- src/db.c | 1 +
- src/package.c | 1 +
- src/transaction.c | 1 +
- 3 files changed, 3 insertions(+)
-
-diff --git a/src/db.c b/src/db.c
-index 8b9ffd2..fae8edb 100644
---- a/src/db.c
-+++ b/src/db.c
-@@ -20,6 +20,7 @@
- *
- */
-
-+#include <pyconfig.h>
- #include <alpm.h>
- #include <Python.h>
- #include "db.h"
-diff --git a/src/package.c b/src/package.c
-index d4ab941..bd08c25 100644
---- a/src/package.c
-+++ b/src/package.c
-@@ -20,6 +20,7 @@
- *
- */
-
-+#include <pyconfig.h>
- #include <string.h>
- #include <alpm.h>
- #include <Python.h>
-diff --git a/src/transaction.c b/src/transaction.c
-index 9c28c50..8cb7e5b 100644
---- a/src/transaction.c
-+++ b/src/transaction.c
-@@ -20,6 +20,7 @@
- *
- */
-
-+#include <pyconfig.h>
- #include <string.h>
- #include <alpm.h>
- #include <Python.h>
---
-2.6.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 7bb55a9542e0..34e471a4e6a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,18 @@
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.r0.g1b5abcf
+pkgver=0.8.1.r0.gda8de1a
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('i686' 'x86_64')
-url="http://projects.archlinux.org/users/remy/pyalpm.git/"
+url="http://projects.archlinux.org/pyalpm.git/"
license=('GPL')
-depends=('python>=3.2' 'pacman>=5')
+depends=('python>=3.6' 'pacman>=5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git')
-source=(
- 'git+https://projects.archlinux.org/git/users/remy/pyalpm.git'
- '0001-Fix-build-for-Python-3.5.patch'
-)
-md5sums=(
- 'SKIP'
- 'd5481d4f9920860518277a78857c25e8'
-)
+source=('git+https://projects.archlinux.org/git/pyalpm.git')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -30,12 +24,6 @@ pkgver() {
)
}
-prepare() {
- cd "$srcdir/$_pkgname"
-
- patch -Np1 -i ../0001-Fix-build-for-Python-3.5.patch
-}
-
package() {
cd "$srcdir/$_pkgname"