summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b32dfa1beb..8257b83b5b13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.8.1.r0.gda8de1a
+ pkgver = 0.8.2.r1.g1f95811
pkgrel = 1
- url = http://projects.archlinux.org/pyalpm.git/
+ url = https://git.archlinux.org/pyalpm.git/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = git
depends = python>=3.6
depends = pacman>=5
- provides = pyalpm=0.8.1.r0.gda8de1a
+ provides = pyalpm=0.8.2.r1.g1f95811
conflicts = pyalpm
source = git+https://projects.archlinux.org/git/pyalpm.git
- md5sums = SKIP
+ source = bpo33012.patch::https://patchwork.archlinux.org/patch/544/raw/
+ sha256sums = SKIP
+ sha256sums = 8006c0252733f76c2af6f69bdaed20c91d8710cb0ce96ce69650b7518c66064d
pkgname = pyalpm-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 5dab2199350e..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-/pyalpm
diff --git a/PKGBUILD b/PKGBUILD
index 34e471a4e6a3..049f66f513e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
-# Contributor: Yen Chi Hsuan <yan12125 at gmail.com>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Dave Reisner <d@falconindy.com>
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.1.r0.gda8de1a
+pkgver=0.8.2.r1.g1f95811
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('i686' 'x86_64')
-url="http://projects.archlinux.org/pyalpm.git/"
-license=('GPL')
+url="https://git.archlinux.org/pyalpm.git/"
+license=('GPL3')
depends=('python>=3.6' 'pacman>=5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git')
-source=('git+https://projects.archlinux.org/git/pyalpm.git')
-md5sums=('SKIP')
+source=('git+https://projects.archlinux.org/git/pyalpm.git'
+ bpo33012.patch::'https://patchwork.archlinux.org/patch/544/raw/')
+sha256sums=('SKIP'
+ '8006c0252733f76c2af6f69bdaed20c91d8710cb0ce96ce69650b7518c66064d')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
+prepare() {
+ cd $_pkgname
+
+ patch -Np1 -i ../bpo33012.patch
+}
+
package() {
- cd "$srcdir/$_pkgname"
+ cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1
}