summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--pacorig-removed-in-pacman5.patch22
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d61ee35b709..4947c5521dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Jan 31 13:29:33 UTC 2016
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
pkgver = 0.6.2.r3.g3c4692b
- pkgrel = 2
+ pkgrel = 3
url = http://projects.archlinux.org/users/remy/pyalpm.git/
arch = i686
arch = x86_64
license = GPL
makedepends = git
depends = python>=3.2
- depends = pacman
+ depends = pacman>=5
provides = pyalpm=0.6.2.r3.g3c4692b
conflicts = pyalpm
source = git+https://projects.archlinux.org/git/users/remy/pyalpm.git
source = 0001-Fix-build-for-Python-3.5.patch
+ source = pacorig-removed-in-pacman5.patch
md5sums = SKIP
md5sums = d5481d4f9920860518277a78857c25e8
+ md5sums = 0bc081273ff6817080cd7c3226413f54
pkgname = pyalpm-git
diff --git a/PKGBUILD b/PKGBUILD
index 883fda198783..567bf75899fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,25 @@
_pkgname=pyalpm
pkgname=$_pkgname-git
pkgver=0.6.2.r3.g3c4692b
-pkgrel=2
+pkgrel=3
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('i686' 'x86_64')
url="http://projects.archlinux.org/users/remy/pyalpm.git/"
license=('GPL')
-depends=('python>=3.2' 'pacman')
+depends=('python>=3.2' 'pacman>=5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git')
source=(
'git+https://projects.archlinux.org/git/users/remy/pyalpm.git'
'0001-Fix-build-for-Python-3.5.patch'
+ # https://lists.archlinux.org/pipermail/arch-projects/2016-January/004320.html
+ 'pacorig-removed-in-pacman5.patch'
)
md5sums=(
'SKIP'
'd5481d4f9920860518277a78857c25e8'
+ '0bc081273ff6817080cd7c3226413f54'
)
pkgver() {
@@ -34,6 +37,7 @@ prepare() {
cd "$srcdir/$_pkgname"
patch -Np1 -i ../0001-Fix-build-for-Python-3.5.patch
+ patch -Np1 -i ../pacorig-removed-in-pacman5.patch
}
package() {
diff --git a/pacorig-removed-in-pacman5.patch b/pacorig-removed-in-pacman5.patch
new file mode 100644
index 000000000000..98ad561d8c60
--- /dev/null
+++ b/pacorig-removed-in-pacman5.patch
@@ -0,0 +1,22 @@
+Support for .pacorig files has been removed in
+libalpm, so remove the relevant event case.
+
+Signed-off-by: Jelle van der Waa <jelle at vdwaa.nl>
+---
+ src/transaction.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/transaction.c b/src/transaction.c
+index 9c28c50..4e681f8 100644
+--- a/src/transaction.c
++++ b/src/transaction.c
+@@ -141,7 +141,6 @@ void pyalpm_eventcb(alpm_event_t *event) {
+ case ALPM_EVENT_KEY_DOWNLOAD_DONE:
+ case ALPM_EVENT_PACNEW_CREATED:
+ case ALPM_EVENT_PACSAVE_CREATED:
+- case ALPM_EVENT_PACORIG_CREATED:
+ default:
+ eventstr = "unknown event";
+ }
+--
+2.7.0