summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b681a3680fdd..f17f49b12fbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pybitmessage
pkgdesc = Decentralized and trustless P2P communications protocol for sending encrypted messages to another person or to many subscribers
pkgver = 0.6.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Bitmessage/PyBitmessage
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 18962800026c..29d459fb2522 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pybitmessage
_realname=PyBitmessage
pkgver=0.6.2
-pkgrel=2
+pkgrel=3
pkgdesc="Decentralized and trustless P2P communications protocol for sending encrypted messages to another person or to many subscribers"
arch=('any')
depends=('openssl' 'python2' 'python2-pyqt4' 'python2-msgpack' 'qt4' 'sqlite')
@@ -28,6 +28,11 @@ prepare() {
find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
}
+build() {
+ cd "$srcdir/$_realname-$pkgver/src/bitmsghash"
+ make
+}
+
package() {
cd "$srcdir/$_realname-$pkgver"