summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
-rw-r--r--configure.patch19
-rw-r--r--pybliographer.install51
4 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c33a7839689e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.0
+# Mon Feb 2 21:05:08 UTC 2015
+pkgbase = pybliographer
+ pkgdesc = A tool for managing bibliographic database
+ pkgver = 1.2.16
+ pkgrel = 1
+ url = http://www.pybliographer.org
+ install = pybliographer.install
+ arch = any
+ license = GPL
+ depends = python-bibtex
+ depends = gconf
+ depends = rarian
+ depends = gnome-doc-utils
+ depends = desktop-file-utils
+ optdepends = gnome-python: for the pybliographic program
+ source = http://downloads.sourceforge.net/project/pybliographer/Sources%20-%201.2/1.2.16/pybliographer-1.2.16.tar.xz
+ source = configure.patch
+ md5sums = 034b2d58dc75ca3f1389494e9f5ee9aa
+ md5sums = ef198b2995d8c6842bbb839893fa798c
+
+pkgname = pybliographer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4222b9619537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Reuben <projectdelphai at gmail dot com>
+# Contributor: Chad Aeschliman <chadaeschliman at gmail dot com>
+# Contributor: Wael Nasreddine <gandalf@siemens-mobiles.org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=pybliographer
+pkgver=1.2.16
+pkgrel=1
+pkgdesc="A tool for managing bibliographic database"
+depends=('python-bibtex' 'gconf' 'rarian' 'gnome-doc-utils' 'desktop-file-utils')
+optdepends=('gnome-python: for the pybliographic program')
+arch=('any')
+license=('GPL')
+install=pybliographer.install
+url="http://www.pybliographer.org"
+source=(http://downloads.sourceforge.net/project/pybliographer/Sources%20-%201.2/1.2.16/pybliographer-1.2.16.tar.xz configure.patch)
+md5sums=('034b2d58dc75ca3f1389494e9f5ee9aa' 'ef198b2995d8c6842bbb839893fa798c')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -i $srcdir/configure.patch
+
+ ./configure --prefix=/usr --disable-depchecks || return 1
+ make || return 1
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR=$pkgdir install || return 1
+
+ # This soft is insisting on mime pfff
+ rm -f $pkgdir/usr/share/applications/mimeinfo.cache || return 1
+}
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..e84e71c47706
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,19 @@
+*** configure_old 2010-10-12 10:54:27.000000000 -0400
+--- configure 2010-11-30 17:44:31.476894402 -0500
+***************
+*** 2215,2221 ****
+
+
+ # Extract the first word of "python", so it can be a program name with args.
+! set dummy python; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
+ if test "${ac_cv_path_Python+set}" = set; then :
+--- 2215,2221 ----
+
+
+ # Extract the first word of "python", so it can be a program name with args.
+! set dummy python2; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
+ if test "${ac_cv_path_Python+set}" = set; then :
diff --git a/pybliographer.install b/pybliographer.install
new file mode 100644
index 000000000000..47d66526ba9b
--- /dev/null
+++ b/pybliographer.install
@@ -0,0 +1,51 @@
+pkgname=pybliographer
+
+post_install() {
+ schemas=(`pacman -Ql $pkgname | grep 'gconf/schemas/.*schemas$' | awk '{ print $2 }'`)
+ scrolls=(`pacman -Ql $pkgname | grep 'share/omf/.*\.omf$' | awk '{ print $2 }'`)
+
+ export GCONF_CONFIG_SOURCE=`usr/bin/gconftool-2 --get-default-source`
+ for schema in "${schemas[@]}" ; do
+ usr/bin/gconftool-2 --makefile-install-rule "$schema" >/dev/null 2>&1
+ done
+
+ for scroll in "${scrolls[@]}" ; do
+ scrollkeeper-install -q -p var/lib/scrollkeeper "$scroll"
+ done
+
+ kill -s HUP `pidof /usr/bin/gconfd-2` > /dev/null 2>&1
+ update-desktop-database -q
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ schemas=(`pacman -Ql $pkgname | grep 'gconf/schemas/.*schemas$' | awk '{ print $2 }'`)
+ scrolls=(`pacman -Ql $pkgname | grep 'share/omf/.*\.omf$' | awk '{ print $2 }'`)
+
+ export GCONF_CONFIG_SOURCE=`usr/bin/gconftool-2 --get-default-source`
+ for schema in "${schemas[@]}" ; do
+ usr/bin/gconftool-2 --makefile-uninstall-rule "$schema" >/dev/null 2>&1
+ done
+
+ for scroll in "${scrolls[@]}" ; do
+ scrollkeeper-uninstall -q -p var/lib/scrollkeeper "$scroll"
+ done
+
+ kill -s HUP `pidof /usr/bin/gconfd-2` >/dev/null 2>&1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+op=$1
+shift
+
+$op $*