summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--pyca-agentstate.service15
-rw-r--r--pyca-capture.service15
-rw-r--r--pyca-ingest.service15
-rw-r--r--pyca-schedule.service15
-rw-r--r--pyca-ui.service (renamed from pycaui.service)0
-rw-r--r--pyca.service (renamed from pyca@.service)4
-rw-r--r--pyca.target5
9 files changed, 92 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bba7334d6ec..788055add450 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyca
pkgdesc = Python Capture Agent for Opencast
pkgver = 2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/opencast/pyCA
install = pyca.install
arch = any
@@ -15,14 +15,20 @@ pkgbase = pyca
optdepends = gunicorn: wsgi web interface
source = https://github.com/opencast/pyCA/archive/v2.1.tar.gz
source = pyca.install
- source = pyca@.service
- source = pycaui.service
- source = pyca.target
+ source = pyca.service
+ source = pyca-ui.service
+ source = pyca-agentstate.service
+ source = pyca-capture.service
+ source = pyca-ingest.service
+ source = pyca-schedule.service
md5sums = c48f246eff3e33a04310da39c01578bf
md5sums = d16c4e1a394f0cf356f65555e8cb0334
- md5sums = 10481ad2e93cac66ed5086b82b7627af
+ md5sums = c014533da3c3b9bb763419e2721e844a
md5sums = 8d7c9144827127d4bb7f65958dbd7683
- md5sums = d411287de5dcc0e1ff6d8de5350918eb
+ md5sums = 3d64e43407482b906b5e21f2a5584a6e
+ md5sums = 2eb31065c6d4deb6888c3b187565add9
+ md5sums = 4adcf6d8ff3641ad1dd4910a1957c9db
+ md5sums = e86a4025da5842d701a12cc258116c66
pkgname = pyca
diff --git a/PKGBUILD b/PKGBUILD
index 7333e766d76f..5331dda8e172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Jan Koppe <post@jankoppe.de>
pkgname=pyca
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python Capture Agent for Opencast"
arch=('any')
url="https://github.com/opencast/pyCA"
@@ -10,15 +10,21 @@ depends=('gnutls' 'python-dateutil' 'python-configobj' 'python-flask' 'python-py
optdepends=('gunicorn: wsgi web interface')
source=("https://github.com/opencast/pyCA/archive/v$pkgver.tar.gz"
"pyca.install"
- "pyca@.service"
- "pycaui.service"
- "pyca.target")
+ "pyca.service"
+ "pyca-ui.service"
+ "pyca-agentstate.service"
+ "pyca-capture.service"
+ "pyca-ingest.service"
+ "pyca-schedule.service")
install="pyca.install"
md5sums=('c48f246eff3e33a04310da39c01578bf'
'd16c4e1a394f0cf356f65555e8cb0334'
- '10481ad2e93cac66ed5086b82b7627af'
+ 'c014533da3c3b9bb763419e2721e844a'
'8d7c9144827127d4bb7f65958dbd7683'
- 'd411287de5dcc0e1ff6d8de5350918eb')
+ '3d64e43407482b906b5e21f2a5584a6e'
+ '2eb31065c6d4deb6888c3b187565add9'
+ '4adcf6d8ff3641ad1dd4910a1957c9db'
+ 'e86a4025da5842d701a12cc258116c66')
prepare() {
cd pyCA-"${pkgver}"
@@ -26,22 +32,17 @@ prepare() {
# Change default locations for recordings and the internal sqlite database
sed -i 's/directory\s*=.*/directory = \/var\/lib\/pyca\/recordings\//' etc/pyca.conf
sed -i 's/#database\s*=.*/database = sqlite:\/\/\/\/var\/lib\/pyca\/pyca.db/' etc/pyca.conf
-
- # Backport a minor fix in agentstate worker, see https://github.com/opencast/pyCA/pull/96
- sed -i 's/while not terminate and/while not terminate() and/g' pyca/agentstate.py
}
package() {
cd pyCA-"${pkgver}"
- install -Dm 644 "${srcdir}"/pyca.target "${pkgdir}"/usr/lib/systemd/system/pyca.target
- install -Dm 644 "${srcdir}"/pyca@.service "${pkgdir}"/usr/lib/systemd/system/pyca@.service
- install -Dm 644 "${srcdir}"/pycaui.service "${pkgdir}"/usr/lib/systemd/system/pycaui.service
- install -dm 755 "${pkgdir}"/usr/lib/systemd/system/pyca.target.wants
- ln -s /usr/lib/systemd/system/pyca@agentstate.service "${pkgdir}"/usr/lib/systemd/system/pyca.target.wants/pyca@agentstate.service
- ln -s /usr/lib/systemd/system/pyca@capture.service "${pkgdir}"/usr/lib/systemd/system/pyca.target.wants/pyca@capture.service
- ln -s /usr/lib/systemd/system/pyca@ingest.service "${pkgdir}"/usr/lib/systemd/system/pyca.target.wants/pyca@ingest.service
- ln -s /usr/lib/systemd/system/pyca@schedule.service "${pkgdir}"/usr/lib/systemd/system/pyca.target.wants/pyca@schedule.service
+ install -Dm 644 "${srcdir}"/pyca.service "${pkgdir}"/usr/lib/systemd/system/pyca.service
+ install -Dm 644 "${srcdir}"/pyca-agentstate.service "${pkgdir}"/usr/lib/systemd/system/pyca-agentstate.service
+ install -Dm 644 "${srcdir}"/pyca-capture.service "${pkgdir}"/usr/lib/systemd/system/pyca-capture.service
+ install -Dm 644 "${srcdir}"/pyca-ingest.service "${pkgdir}"/usr/lib/systemd/system/pyca-ingest.service
+ install -Dm 644 "${srcdir}"/pyca-schedule.service "${pkgdir}"/usr/lib/systemd/system/pyca-schedule.service
+ install -Dm 644 "${srcdir}"/pyca-ui.service "${pkgdir}"/usr/lib/systemd/system/pyca-ui.service
install -dm 755 "${pkgdir}"/var/lib/pyca/recordings
install -dm 755 "${pkgdir}"/usr/lib/python3.6/site-packages/pyca
diff --git a/pyca-agentstate.service b/pyca-agentstate.service
new file mode 100644
index 000000000000..fde29d679329
--- /dev/null
+++ b/pyca-agentstate.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Python Capture Agent agentstate service
+Documentation=https://github.com/opencast/pyCA
+Wants=network.target
+
+[Service]
+Type=simple
+User=pyca
+ExecStart=/usr/bin/pyca agentstate
+Restart=always
+RestartSec=10
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pyca-capture.service b/pyca-capture.service
new file mode 100644
index 000000000000..5f6f091acbc8
--- /dev/null
+++ b/pyca-capture.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Python Capture Agent capture service
+Documentation=https://github.com/opencast/pyCA
+Wants=network.target
+
+[Service]
+Type=simple
+User=pyca
+ExecStart=/usr/bin/pyca capture
+Restart=always
+RestartSec=10
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pyca-ingest.service b/pyca-ingest.service
new file mode 100644
index 000000000000..e1c542ac7763
--- /dev/null
+++ b/pyca-ingest.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Python Capture Agent ingest service
+Documentation=https://github.com/opencast/pyCA
+Wants=network.target
+
+[Service]
+Type=simple
+User=pyca
+ExecStart=/usr/bin/pyca ingest
+Restart=always
+RestartSec=10
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pyca-schedule.service b/pyca-schedule.service
new file mode 100644
index 000000000000..fe6435369e31
--- /dev/null
+++ b/pyca-schedule.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Python Capture Agent schedule service
+Documentation=https://github.com/opencast/pyCA
+Wants=network.target
+
+[Service]
+Type=simple
+User=pyca
+ExecStart=/usr/bin/pyca schedule
+Restart=always
+RestartSec=10
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pycaui.service b/pyca-ui.service
index d6e87f217bf4..d6e87f217bf4 100644
--- a/pycaui.service
+++ b/pyca-ui.service
diff --git a/pyca@.service b/pyca.service
index b89c7fda9db2..7b997f2afefe 100644
--- a/pyca@.service
+++ b/pyca.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Python Capture Agent %i worker
+Description=Python Capture Agent
Documentation=https://github.com/opencast/pyCA
Wants=network.target
PartOf=pyca.target
@@ -7,7 +7,7 @@ PartOf=pyca.target
[Service]
Type=simple
User=pyca
-ExecStart=/usr/bin/pyca %i
+ExecStart=/usr/bin/pyca
Restart=always
RestartSec=10
TimeoutSec=300
diff --git a/pyca.target b/pyca.target
deleted file mode 100644
index f10a00083970..000000000000
--- a/pyca.target
+++ /dev/null
@@ -1,5 +0,0 @@
-[Unit]
-Description=Python Capture Agent
-Documentation=https://github.com/opencast/pyCA
-Requires=multi-user.target
-Wants=network.target