summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3518500554df..1bcd8474e7a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pycharm-community-eap
pkgdesc = Powerful Python and Django IDE, Early Access Program (EAP) build. Community edition.
- pkgver = 2020.1.201.6073.24
+ pkgver = 2020.1.201.6251.24
pkgrel = 1
epoch = 5
url = http://www.jetbrains.com/pycharm/
@@ -12,8 +12,8 @@ pkgbase = pycharm-community-eap
provides = pycharm-community-edition
conflicts = pycharm-community-edition
options = !strip
- source = https://download.jetbrains.com/python/pycharm-community-201.6073.24.tar.gz
- sha256sums = 197e0572b7daa8a6dc889e910df8117d4a3de44bc88bd50e1592869a7476f975
+ source = https://download.jetbrains.com/python/pycharm-community-201.6251.24.tar.gz
+ sha256sums = 8b6d2990d3fc03b9aea2e4ca121ec2a2629e9f0f2b404b603d47eb43c7c6a0de
pkgname = pycharm-community-eap
diff --git a/PKGBUILD b/PKGBUILD
index 6e9d0b88fe67..027c525cb19b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pycharm-community-eap
-_buildver=201.6073.24
+_buildver=201.6251.24
_pkgver=2020.1
_eap=y
pkgver="$_pkgver.$_buildver"
@@ -13,14 +13,14 @@ epoch=5
pkgdesc='Powerful Python and Django IDE, Early Access Program (EAP) build. Community edition.'
arch=('any')
-url='http://www.jetbrains.com/pycharm/'
+url=http://www.jetbrains.com/pycharm/
license=('Apache')
provides=('pycharm-community-edition')
conflicts=('pycharm-community-edition')
-depends=('libdbusmenu-glib')
makedepends=('python-setuptools' 'python2-setuptools')
+depends=('libdbusmenu-glib')
options=('!strip')
@@ -30,7 +30,10 @@ else
_filever="$_pkgver"
fi
source=("https://download.jetbrains.com/python/pycharm-community-$_filever.tar.gz")
-sha256sums=($(curl -s "https://download.jetbrains.com/python/pycharm-community-$_filever.tar.gz.sha256" | cut -d' ' -f1))
+# The website doesn't provide the checksum atm, so we hard code it in the PKGBUILD for the time being
+#sha256sums=($(curl -s "https://download.jetbrains.com/python/pycharm-community-$_filever.tar.gz.sha256" | cut -d' ' -f1))
+sha256sums=('8b6d2990d3fc03b9aea2e4ca121ec2a2629e9f0f2b404b603d47eb43c7c6a0de')
+
prepare() {
if [ -d "pycharm-community-$_pkgver" ]; then