summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
-rw-r--r--charm.desktop4
-rw-r--r--pycharm6
-rw-r--r--pycharm-professional.desktop13
-rw-r--r--pycharm-professional.install12
6 files changed, 35 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a30951e85b..8423c4a8f98b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pycharm-professional
- pkgdesc = Powerful Python and Django IDE. Professional edition.
- pkgver = 2018.2.2
+ pkgdesc = Powerful Python and Django IDE. Professional Edition.
+ pkgver = 2018.2.3
pkgrel = 1
url = http://www.jetbrains.com/pycharm/
install = pycharm-professional.install
@@ -8,13 +8,13 @@ pkgbase = pycharm-professional
license = custom
makedepends = python2-setuptools
makedepends = python-setuptools
- depends = gcc-libs
depends = giflib
depends = glibc
depends = sh
depends = ttf-font
depends = libxtst
depends = libxslt
+ depends = python
optdepends = ipython2: For enhanced interactive Python shell v2 inside Pycharm
optdepends = ipython: For enhanced interactive Python shell v3 inside Pycharm
optdepends = openssh: For deployment and remote connections
@@ -37,17 +37,17 @@ pkgbase = pycharm-professional
conflicts = pycharm-community
backup = opt/pycharm-professional/bin/pycharm.vmoptions
backup = opt/pycharm-professional/bin/pycharm64.vmoptions
- source = https://download.jetbrains.com/python/pycharm-professional-2018.2.2.tar.gz
+ source = https://download.jetbrains.com/python/pycharm-professional-2018.2.3.tar.gz
source = pycharm-professional.desktop
source = pycharm-professional.install
source = pycharm
source = charm.desktop
source = charm
- sha256sums = e7ce851728c411ff2112b82bfabbcb8d20d0433a8d7ce06887588cb278f8c8b1
- sha256sums = 016db1860a8b36d408c827f90aeb04b9d55cf21ea36788a9d8510cc54fae1c49
- sha256sums = fecb420a4644255cfbb486c1c82644e17e523bb61707108689f4fb702549d0eb
- sha256sums = 54603a788b4ecad5d0a92e5b7fe37a98979250d2b5fd7d037759b4254b0b1607
- sha256sums = e1cf2a280d90a55710131bdf33f4026a427d10131ddd5c776a936ee1ecf5a6fb
+ sha256sums = 141669a6e8073da0fa328a4aa749fb79a1342ee68edcaee19023e7d59a9dc548
+ sha256sums = aaf7113e8c56e4d977eca204d57350d9493eda2710abefd2488a2b5d47c53344
+ sha256sums = 40b297ac1d883583ed5d7aae75fb09497a2af5bda9dd4aff83bd6d2892ab6c95
+ sha256sums = 818ed42f4200ae13315587abf6f247f93e68c658a94794f73924c985cdc145d0
+ sha256sums = 21e77b6b18e14636f9827e1f8d45bbc8dba8fb14ea5f4cde285c1ef4bb01c85e
sha256sums = 7e9bc3873f6c8039b4d7c181806ce4363632ff5811e966142749396cd849d86f
pkgname = pycharm-professional
diff --git a/PKGBUILD b/PKGBUILD
index 7abc6727d456..f8baf7ba4b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
pkgname=pycharm-professional
-pkgver=2018.2.2
-_pkgver=2018.2.2
+pkgver=2018.2.3
+_pkgver=2018.2.3
pkgrel=1
-pkgdesc="Powerful Python and Django IDE. Professional edition."
+pkgdesc="Powerful Python and Django IDE. Professional Edition."
arch=('x86_64')
url='http://www.jetbrains.com/pycharm/'
conflicts=('pycharm' 'pycharm-community')
@@ -12,7 +12,7 @@ provides=('pycharm')
license=('custom')
install=${pkgname}.install
backup=(opt/$pkgname/bin/pycharm.vmoptions opt/$pkgname/bin/pycharm64.vmoptions)
-depends=('gcc-libs' 'giflib' 'glibc' 'sh' 'ttf-font' 'libxtst' 'libxslt')
+depends=('giflib' 'glibc' 'sh' 'ttf-font' 'libxtst' 'libxslt' 'python')
source=(https://download.jetbrains.com/python/$pkgname-$_pkgver.tar.gz
'pycharm-professional.desktop'
'pycharm-professional.install'
@@ -20,11 +20,11 @@ source=(https://download.jetbrains.com/python/$pkgname-$_pkgver.tar.gz
'charm.desktop'
'charm')
# https://download.jetbrains.com/python/pycharm-professional-${_pkgver}.tar.gz.sha256
-sha256sums=('e7ce851728c411ff2112b82bfabbcb8d20d0433a8d7ce06887588cb278f8c8b1'
- '016db1860a8b36d408c827f90aeb04b9d55cf21ea36788a9d8510cc54fae1c49'
- 'fecb420a4644255cfbb486c1c82644e17e523bb61707108689f4fb702549d0eb'
- '54603a788b4ecad5d0a92e5b7fe37a98979250d2b5fd7d037759b4254b0b1607'
- 'e1cf2a280d90a55710131bdf33f4026a427d10131ddd5c776a936ee1ecf5a6fb'
+sha256sums=('141669a6e8073da0fa328a4aa749fb79a1342ee68edcaee19023e7d59a9dc548'
+ 'aaf7113e8c56e4d977eca204d57350d9493eda2710abefd2488a2b5d47c53344'
+ '40b297ac1d883583ed5d7aae75fb09497a2af5bda9dd4aff83bd6d2892ab6c95'
+ '818ed42f4200ae13315587abf6f247f93e68c658a94794f73924c985cdc145d0'
+ '21e77b6b18e14636f9827e1f8d45bbc8dba8fb14ea5f4cde285c1ef4bb01c85e'
'7e9bc3873f6c8039b4d7c181806ce4363632ff5811e966142749396cd849d86f')
makedepends=('python2-setuptools' 'python-setuptools')
optdepends=('ipython2: For enhanced interactive Python shell v2 inside Pycharm'
@@ -56,6 +56,9 @@ build() {
}
package() {
+ # workaround FS#40934
+ sed -i 's/lcd/on/' pycharm-$_pkgver/bin/*.vmoptions
+
# base
install -dm 755 $pkgdir/opt/$pkgname
cp -dr --no-preserve=ownership pycharm-$_pkgver/* $pkgdir/opt/$pkgname
diff --git a/charm.desktop b/charm.desktop
index c79989db147c..c27b2c902180 100644
--- a/charm.desktop
+++ b/charm.desktop
@@ -1,10 +1,10 @@
[Desktop Entry]
+Type=Application
Name=Charm
Icon=pycharm
-Exec=source ~/.bash_profile;/opt/pycharm-professional/bin/charm
+Exec=/opt/pycharm-professional/bin/charm %f
MimeType=text/x-python;application/x-ipynb+json
NoDisplay=true
-Type=Application
Terminal=false
StartupNotify=true
StartupWMClass=jetbrains-pycharm
diff --git a/pycharm b/pycharm
index f9538f465a93..88f7989d4a55 100644
--- a/pycharm
+++ b/pycharm
@@ -1,5 +1,3 @@
-#!/bin/bash -l
+#!/bin/sh
-[[ -f ~/.bash_profile ]] && . ~/.bash_profile
-
-sh /opt/pycharm-professional/bin/pycharm.sh "$@"
+exec /opt/pycharm-professional/bin/pycharm.sh "$@"
diff --git a/pycharm-professional.desktop b/pycharm-professional.desktop
index 714570817e74..29a3ee0df6fc 100644
--- a/pycharm-professional.desktop
+++ b/pycharm-professional.desktop
@@ -1,11 +1,10 @@
[Desktop Entry]
-Name=PyCharm
+Type=Application
+Name=PyCharm Professional Edition
Icon=pycharm
-GenericName=Python and Django IDE
-Comment=Powerful Python and Django IDE. Professional version.
-Exec=/usr/bin/pycharm
+Comment=Python IDE for Professional Developers.
+Exec=/usr/bin/pycharm %f
Terminal=false
-Type=Application
-Categories=Development;IDE;
+Categories=Development;IDE;Python;
StartupNotify=true
-StartupWMClass=jetbrains-pycharm \ No newline at end of file
+StartupWMClass=jetbrains-pycharm
diff --git a/pycharm-professional.install b/pycharm-professional.install
index 5f65abed5c46..028a44f90c68 100644
--- a/pycharm-professional.install
+++ b/pycharm-professional.install
@@ -1,16 +1,12 @@
post_install() {
/bin/cat << EOF
===>
-===> Please set the Anti-aliasing font settings for Java app
-===> adding the following line to the user's file ~/.bash_profile
-===> (not in ~/.bashrc):
+===> Please set the anti-aliasing font and others settings of
+===> pycharm in this file (if is needed):
===>
-===> export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=setting'
-===>
-===> Replace 'setting' with on, lcd, gasp, etc. By default is
-===> configured with lcd.
+===> /opt/pycharm-professional/bin/pycharm64.vmoptions
===>
-===> Please read the following link for more options:
+===> Please read the following link for more font options:
===> https://wiki.archlinux.org/index.php/Java_Runtime_Environment_Fonts
===>
EOF