summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
-rw-r--r--pycom-fwtool.desktop (renamed from lopyupdate.desktop)3
3 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97bb3cf590b7..9aac242b6c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
# Generated by mksrcinfo v8
-# Sat Jun 2 21:06:55 UTC 2018
+# Sun Jun 3 22:15:59 UTC 2018
pkgbase = pycom-firmware-updater
pkgdesc = Pycom firmware updater for WiPy and LoPy IOT boards
- pkgver = 1.14.5
+ pkgver = 1.15.0
pkgrel = 1
url = https://www.pycom.io/
- arch = any
+ arch = x86_64
+ arch = i686
license = GPL-3
depends = dialog
depends = python2
@@ -13,12 +14,14 @@ pkgbase = pycom-firmware-updater
optdepends = python2-pyserial: gui
optdepends = python2-setuptools: gui
optdepends = python2-requests: gui
- source = https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=unix&redirect=true
- source = lopyupdate.sh
- source = lopyupdate.desktop
- md5sums = 5e1cbe55102b78ea8f419e23033858c1
- md5sums = 268d38fbb3f7d8ee962760abb6169505
- md5sums = 6af9152e7aa93baa74b59cbc0af2ba71
+ source_x86_64 = https://software.pycom.io/downloads/pycom_firmware_update_1.15.0-amd64.tar.gz
+ source_x86_64 = pycom-fwtool.desktop
+ md5sums_x86_64 = 1ed70a132db954affa431351c70ba3f9
+ md5sums_x86_64 = b9adb203ada3eb0ba6f1aaa0b74d609a
+ source_i686 = https://software.pycom.io/downloads/pycom_firmware_update_1.15.0-i386.tar.gz
+ source_i686 = pycom-fwtool.desktop
+ md5sums_i686 = 4b91a0e06c9d3c7a86dc1dc065e754e4
+ md5sums_i686 = b9adb203ada3eb0ba6f1aaa0b74d609a
pkgname = pycom-firmware-updater
diff --git a/PKGBUILD b/PKGBUILD
index 3138ddeee03a..f1d29dddafe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,27 @@
DLAGENTS=('https::/usr/bin/curl -A "Mozilla/4.0" -fLC - -o %o %u')
pkgname=pycom-firmware-updater
-pkgver=1.14.5
+pkgver=1.15.0
pkgrel=1
pkgdesc="Pycom firmware updater for WiPy and LoPy IOT boards"
url="https://www.pycom.io/"
license=('GPL-3')
-arch=('any')
+arch=('x86_64' 'i686')
depends=('dialog' 'python2')
optdepends=('python2-qscintilla-qt4: gui'
'python2-pyserial: gui'
'python2-setuptools: gui'
'python2-requests: gui')
-source=('https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=unix&redirect=true'
- 'lopyupdate.sh'
- 'lopyupdate.desktop')
-md5sums=('5e1cbe55102b78ea8f419e23033858c1'
- '268d38fbb3f7d8ee962760abb6169505'
- '6af9152e7aa93baa74b59cbc0af2ba71')
+source_x86_64=('https://software.pycom.io/downloads/pycom_firmware_update_1.15.0-amd64.tar.gz'
+ 'pycom-fwtool.desktop')
+source_i686=('https://software.pycom.io/downloads/pycom_firmware_update_1.15.0-i386.tar.gz'
+ 'pycom-fwtool.desktop')
+
+md5sums_x86_64=('1ed70a132db954affa431351c70ba3f9'
+ 'b9adb203ada3eb0ba6f1aaa0b74d609a')
+
+md5sums_i686=('4b91a0e06c9d3c7a86dc1dc065e754e4'
+ 'b9adb203ada3eb0ba6f1aaa0b74d609a')
prepare() {
cd $srcdir
@@ -28,8 +32,10 @@ prepare() {
package() {
mkdir -p $pkgdir/usr/{share,bin}
cd $srcdir
- cp -r pyupgrade $pkgdir/usr/share
- ln -s /usr/share/pyupgrade/update $pkgdir/usr/bin/pycom-firmware-update
- install -Dm755 $srcdir/lopyupdate.sh $pkgdir/usr/bin/lopyupdate.sh
- install -Dm644 lopyupdate.desktop "$pkgdir"/usr/share/applications/lopyupdate.desktop
+ cp -r * $pkgdir/usr/share
+ ln -s /usr/share/pyupgrade/pycom-fwtool $pkgdir/usr/bin/pycom-fwtool
+ ln -s /usr/share/pyupgrade/pycom-fwtool-cli $pkgdir/usr/bin/pycom-fwtool-cli
+ ln -s /usr/share/pyupgrade/pycom-update $pkgdir/usr/bin/pycom-update
+ install -Dm644 pycom-fwtool.desktop "$pkgdir"/usr/share/applications/pycom-fwtool.desktop
+ install -Dm644 $srcdir/pyupgrade/res/py.png $pkgdir/usr/share/pixmaps/pycom-fwtool.png
}
diff --git a/lopyupdate.desktop b/pycom-fwtool.desktop
index 0e53cbb15e50..c087ab732b3e 100644
--- a/lopyupdate.desktop
+++ b/pycom-fwtool.desktop
@@ -1,10 +1,11 @@
[Desktop Entry]
Version=1.0
Type=Application
-Exec=/usr/bin/lopyupdate.sh
+Exec=pycom-fwtool
Terminal=false
Name=PyCom Firmware Update tool
Comment=Firmware update tool for LoPy and WiPy boards
GenericName=Firmware updater by PyCom
+Icon=pycom-fwtool
Categories=Development;
StartupNotify=true