summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75976a163f5f..2eb89b549264 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = pyg3t-git
pkgdesc = Python GetText Translation Toolkit
- pkgver = 0.5.1.r328.417e7a8
+ pkgver = 0.5.1.r401.3939d89
pkgrel = 1
- url = https://github.com/pyg3t/pyg3t
+ url = https://gitlab.com/pyg3t/pyg3t
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
+ checkdepends = python-pytest
makedepends = git
- depends = python-dateutil
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
provides = pyg3t
conflicts = pyg3t
- source = git+https://github.com/pyg3t/pyg3t.git
+ source = git+https://gitlab.com/pyg3t/pyg3t.git
md5sums = SKIP
pkgname = pyg3t-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 14f744769987..74147d9e37b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
_name=pyg3t
pkgname=$_name-git
-pkgver=0.5.1.r328.417e7a8
+pkgver=0.5.1.r401.3939d89
pkgrel=1
pkgdesc="Python GetText Translation Toolkit"
arch=(any)
-url="https://github.com/pyg3t/pyg3t"
-license=('GPL3')
-depends=('python-dateutil')
-makedepends=('git')
+url="https://gitlab.com/pyg3t/pyg3t"
+license=(GPL-3.0-or-later)
+depends=(python)
+makedepends=(git python-setuptools python-build python-installer python-wheel)
+checkdepends=(python-pytest)
provides=($_name)
conflicts=($_name)
source=(git+${url}.git)
@@ -24,11 +25,19 @@ pkgver() {
}
build() {
- cd "$srcdir/$_name"
- python setup.py build
+ cd $_name
+ python -m build --wheel --no-isolation
+}
+
+# Workaround for the tests requiring installed scripts (poselect, etc.)
+check() {
+ cd $_name
+ python -m installer --destdir='tmp_dir' dist/*.whl
+ export PATH="$PWD/tmp_dir/usr/bin:$PATH"
+ PYTHONPATH=$PWD python -m pytest -vv
}
package() {
- cd "$srcdir/$_name"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $_name
+ python -m installer --destdir="$pkgdir" dist/*.whl
}