summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db870bc4b08a..b0d461515496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
-# Generated by mksrcinfo v8
-# Sat Apr 22 07:45:34 UTC 2017
pkgbase = pylibgamma
pkgdesc = Display server abstraction layer for gamma ramps and Python 3
- pkgver = 1.1.2
+ pkgver = 1.1.3
pkgrel = 1
- url = https://github.com/maandree/pylibgamma
+ url = https://codeberg.org/maandree/pylibgamma
arch = i686
arch = x86_64
- license = GPL3
+ license = custom:ISC
makedepends = python3
makedepends = libgamma>=0.6
makedepends = glibc
@@ -19,8 +17,7 @@ pkgbase = pylibgamma
depends = python3
depends = libgamma>=0.6
depends = glibc
- source = https://github.com/maandree/pylibgamma/archive/1.1.2.tar.gz
- sha256sums = e40f1291712e799d28eb4b4c5df9fe6b07ce5f0bf39bcd7f9416fb9d3335fb9a
+ source = pylibgamma-1.1.3.tar.gz::https://codeberg.org/maandree/pylibgamma/archive/1.1.3.tar.gz
+ sha256sums = 09b4225384e5d8d0d55323b97d57ec435326275f935e41097eddbc9953c4bb33
pkgname = pylibgamma
-
diff --git a/PKGBUILD b/PKGBUILD
index 268d18eeed6f..64448434d163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
pkgname=pylibgamma
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
pkgdesc="Display server abstraction layer for gamma ramps and Python 3"
arch=(i686 x86_64)
-url="https://github.com/maandree/pylibgamma"
-license=('GPL3')
+url="https://codeberg.org/maandree/pylibgamma"
+license=('custom:ISC')
depends=(python3 'libgamma>=0.6' glibc)
makedepends=(python3 'libgamma>=0.6' glibc make gcc cython coreutils pkg-config)
-source=($url/archive/$pkgver.tar.gz)
-sha256sums=(e40f1291712e799d28eb4b4c5df9fe6b07ce5f0bf39bcd7f9416fb9d3335fb9a)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(09b4225384e5d8d0d55323b97d57ec435326275f935e41097eddbc9953c4bb33)
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
}
-