summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD100
2 files changed, 60 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e14e7fe148..34beb68c46b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
pkgbase = pyload-git
pkgdesc = Downloadtool for One-Click-Hoster written in python. Latest stable branch
- pkgver = 0.4.20.r12.g33b8c7b9f
+ pkgver = 0.4.20.r211.4b905ceb5
pkgrel = 1
- url = https://github.com/pyload/pyload/tree/stable
+ url = https://pyload.net/
install = pyload-git.install
arch = any
license = GPL
makedepends = git
depends = python2
depends = python2-crypto
- depends = python2-pycurl
- depends = tesseract
depends = python2-imaging
+ depends = python2-pycurl
depends = python2-pyopenssl
- optdepends = python2-pyqt: Gui
+ depends = tesseract
+ optdepends = js68: ClickNLoad
optdepends = python2-flup: for additional webservers
optdepends = python2-notify: Notifications for GUI
- optdepends = js60: ClickNLoad
+ optdepends = python2-pyqt: Gui
provides = pyload
conflicts = pyload
- conflicts = pyload-hg
backup = var/lib/pyload/pyload.conf
source = pyload::git+https://github.com/pyload/pyload.git#branch=stable
source = http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload-gui.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 382bab11398a..2a655b4489e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,76 +1,84 @@
# Maintainer: robertfoster
pkgname=pyload-git
-pkgver=0.4.20.r12.g33b8c7b9f
+pkgver=0.4.20.r211.4b905ceb5
pkgrel=1
pkgdesc="Downloadtool for One-Click-Hoster written in python. Latest stable branch"
-url="https://github.com/pyload/pyload/tree/stable"
+url="https://pyload.net/"
license=('GPL')
arch=('any')
-provides=('pyload')
-conflicts=('pyload' 'pyload-hg')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
backup=('var/lib/pyload/pyload.conf')
-depends=('python2' 'python2-crypto' 'python2-pycurl' 'tesseract'
-'python2-imaging' 'python2-pyopenssl')
-optdepends=('python2-pyqt: Gui'
- 'python2-flup: for additional webservers'
- 'python2-notify: Notifications for GUI'
-'js60: ClickNLoad')
+depends=('python2' 'python2-crypto' 'python2-imaging' 'python2-pycurl' 'python2-pyopenssl' 'tesseract')
+optdepends=('js68: ClickNLoad'
+ 'python2-flup: for additional webservers'
+ 'python2-notify: Notifications for GUI'
+ 'python2-pyqt: Gui')
makedepends=('git')
install='pyload-git.install'
-source=('pyload::git+https://github.com/pyload/pyload.git#branch=stable'
- 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload-gui.desktop'
- 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload.desktop'
- 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload-gui.png'
- 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload.svg'
-'pyload.service' 'pyload.conf' 'pyLoadCore' 'pyLoadCli' 'pyLoadGui')
+source=("${pkgname%-git}::git+https://github.com/pyload/pyload.git#branch=stable"
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload-gui.desktop'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload.desktop'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload-gui.png'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload.svg'
+ 'pyload.service' 'pyload.conf' 'pyLoadCore' 'pyLoadCli' 'pyLoadGui')
pkgver() {
- cd pyload
- git describe --long --tags| sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "${srcdir}/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd ${srcdir}
- sed -i 's_#!/usr/bin/env python$_#!/usr/bin/env python2_' pyload/pyLoad*.py
+ cd "${srcdir}/${pkgname%-git}"
+ sed -i 's_#!/usr/bin/env python$_#!/usr/bin/env python2_' pyLoad*.py
}
build() {
- python2 -O -m compileall ${srcdir}/pyload
+ cd "${srcdir}/${pkgname%-git}"
+ python2 -O -m compileall .
}
package() {
- cd ${srcdir}
+ cd "${srcdir}/"
- install -d -m 755 ${pkgdir}/opt/pyload
- cp -r pyload/* ${pkgdir}/opt/pyload
+ install -dm755 "${pkgdir}/opt/${pkgname%-git}"
+ cp -r "${pkgname%-git}"/* "${pkgdir}/opt/${pkgname%-git}"
- install -d -m 755 ${pkgdir}/usr/share/applications
- install -D -m 644 pyload.desktop ${pkgdir}/usr/share/applications
- install -D -m 644 pyload-gui.desktop ${pkgdir}/usr/share/applications
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -Dm644 "${pkgname%-git}.desktop" \
+ "${pkgdir}/usr/share/applications"
+ install -Dm644 "${pkgname%-git}-gui.desktop" \
+ "${pkgdir}/usr/share/applications"
- install -d -m 755 ${pkgdir}/usr/share/pixmaps
- install -D -m 644 pyload.svg ${pkgdir}/usr/share/pixmaps
- install -D -m 644 pyload-gui.png ${pkgdir}/usr/share/pixmaps
+ # Create desktop icons
+ install -dm755 "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${pkgname%-git}.svg" \
+ "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${pkgname%-git}-gui.png" \
+ "${pkgdir}/usr/share/pixmaps"
- install -d -m 755 ${pkgdir}/usr/bin
- install -D -m 755 pyLoadCore ${pkgdir}/usr/bin/pyLoadCore
- install -D -m 755 pyLoadCli ${pkgdir}/usr/bin/pyLoadCli
- install -D -m 755 pyLoadGui ${pkgdir}/usr/bin/pyLoadGui
+ # Create launcher scripts
+ install -dm755 "${pkgdir}/usr/bin"
+ install -Dm755 pyLoadCore "${pkgdir}/usr/bin/pyLoadCore"
+ install -Dm755 pyLoadCli "${pkgdir}/usr/bin/pyLoadCli"
+ install -Dm755 pyLoadGui "${pkgdir}/usr/bin/pyLoadGui"
- # Create PyLoad service
- install -D -m 644 ${srcdir}/pyload.service ${pkgdir}/usr/lib/systemd/system/pyload.service
- install -D -m 644 ${srcdir}/pyload.conf ${pkgdir}/var/lib/pyload/pyload.conf
+ # Create systemd service
+ install -Dm644 "${pkgname%-git}.service" \
+ "${pkgdir}/usr/lib/systemd/system/${pkgname%-git}.service"
+ install -Dm644 "${pkgname%-git}.conf" \
+ "${pkgdir}/var/lib/${pkgname%-git}/${pkgname%-git}.conf"
}
md5sums=('SKIP'
- 'b96a4e5091463b3b7fd79208623f1a3a'
- 'c67462993d27d5884677dd6e8a8a17d2'
- '73fcec930d25a49e1b99576069d88bd5'
- '649d5af94101655d37fe50e7b127d1b6'
- '454e974b11ab31533423f336c3a182f2'
- '32b00d50be868c165930c592b99730a9'
- '6d764666ec89ce218cd00164e73e0989'
- '6fc2f343d2f324a66745524bbab93e5c'
-'806a22a74e8331dffcb8538182e4df2c')
+ 'b96a4e5091463b3b7fd79208623f1a3a'
+ 'c67462993d27d5884677dd6e8a8a17d2'
+ '73fcec930d25a49e1b99576069d88bd5'
+ '649d5af94101655d37fe50e7b127d1b6'
+ '454e974b11ab31533423f336c3a182f2'
+ '32b00d50be868c165930c592b99730a9'
+ '6d764666ec89ce218cd00164e73e0989'
+ '6fc2f343d2f324a66745524bbab93e5c'
+ '806a22a74e8331dffcb8538182e4df2c')