summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d439baac28b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pypam2-bzr
+ pkgdesc = A Python interface to the PAM library (configured to build for python2)
+ pkgver = 17
+ pkgrel = 1
+ url = https://launchpad.net/ubuntu/quantal/+source/python-pam
+ arch = any
+ license = GPL
+ makedepends = bzr
+ depends = pam
+ depends = python2
+ provides = pypam2
+ conflicts = pypam2
+
+pkgname = pypam2-bzr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..756ec5db318a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+pypam2-bzr-17-1-any.pkg.tar.xz
+pypam2-bzr-17-1-any.pkg.tar.xz.sig
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90d0a290d686
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=pypam2-bzr
+pkgver=17
+pkgrel=1
+arch=('any')
+license=('GPL')
+makedepends=('bzr')
+depends=('pam' 'python2')
+url="https://launchpad.net/ubuntu/quantal/+source/python-pam"
+pkgdesc="A Python interface to the PAM library (configured to build for python2)"
+conflicts=('pypam2')
+provides=('pypam2')
+
+_urel="quantal"
+_bzrtrunk="http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/${_urel}/python-pam/${_urel}"
+_bzrmod=python-pam
+
+build()
+{
+ cd "${srcdir}"
+ if [[ -d "$_bzrmod" ]]; then
+ cd "$_bzrmod" && bzr --no-plugins pull "$_bzrtrunk" -r "$pkgver"
+ msg "The local files are updated."
+ else
+ bzr --no-plugins branch "$_bzrtrunk" "$_bzrmod" -q -r "$pkgver"
+ cd python-pam
+ fi
+ python2 setup.py build
+}
+
+package()
+{
+ cd "${srcdir}/python-pam"
+ python2 setup.py install --root="${pkgdir}"
+}