summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32838f84e6bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pyparticles
+ pkgdesc = Particles simulation toolbox for python, with some force model and integrations methods
+ pkgver = 0.3.5
+ pkgrel = 1
+ url = http://pyparticles.wordpress.com/
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-opengl
+ depends = python2-scipy
+ depends = python2-numpy
+ depends = python2-matplotlib
+ source = http://sourceforge.net/projects/pyparticles/files/PyParticles-0.3.5/pyparticles-0.3.5.tar.gz
+ sha1sums = 89f207b23449f33ca7ece9533d4571ad440fcd91
+
+pkgname = pyparticles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded055576daa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+pkgname=pyparticles
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="Particles simulation toolbox for python, with some force model and integrations methods"
+arch=(any)
+license=('GPL3')
+url="http://pyparticles.wordpress.com/"
+depends=('python2' 'python2-opengl' 'python2-scipy' 'python2-numpy' 'python2-matplotlib' )
+
+
+source=("http://sourceforge.net/projects/pyparticles/files/PyParticles-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('89f207b23449f33ca7ece9533d4571ad440fcd91')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ echo ${pkgdir}
+ python2 setup.py install --root=${pkgdir} --prefix=usr --optimize=1
+}