summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c5b5d9d6150..352e2dd05a64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyruse
pkgdesc = Route systemd-journal logs to filters and actions (ban, report, etc.)
- pkgver = 1.1
+ pkgver = 2.0
pkgrel = 1
url = https://yalis.fr/git/yves/pyruse
arch = any
@@ -10,8 +10,10 @@ pkgbase = pyruse
depends = python>=3.4
depends = python-systemd
optdepends = nftables: for the action_nftBan module
+ optdepends = iptables: for the action_ipsetBan module
+ optdepends = ipset: for the action_ipsetBan module
optdepends = smtp-forwarder: for the action_email and action_dailyReport modules
- source = git+https://yalis.fr/git/yves/pyruse.git#tag=1.1
+ source = git+https://yalis.fr/git/yves/pyruse.git#tag=2.0
sha1sums = SKIP
pkgname = pyruse
diff --git a/PKGBUILD b/PKGBUILD
index 33a3319d1034..b727ff0ffc8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Yves G. <theYinYeti@yalis.fr>
pkgname=pyruse
-pkgver=1.1
+pkgver=2.0
pkgrel=1
pkgdesc="Route systemd-journal logs to filters and actions (ban, report, etc.)"
arch=('any')
@@ -13,6 +13,8 @@ source=("git+https://yalis.fr/git/yves/pyruse.git#tag=${pkgver}")
sha1sums=('SKIP')
optdepends=(
'nftables: for the action_nftBan module'
+ 'iptables: for the action_ipsetBan module'
+ 'ipset: for the action_ipsetBan module'
'smtp-forwarder: for the action_email and action_dailyReport modules'
)
@@ -23,16 +25,18 @@ package() {
mkdir -p "${pkgdir}/etc/systemd/system/pyruse-boot@action_nftBan.service.d"
cp extra/systemd/action_nftBan.conf "${pkgdir}/etc/systemd/system/pyruse-boot@action_nftBan.service.d/"
+ mkdir -p "${pkgdir}/etc/systemd/system/pyruse-boot@action_ipsetBan.service.d"
+ cp extra/systemd/action_ipsetBan.conf "${pkgdir}/etc/systemd/system/pyruse-boot@action_ipsetBan.service.d/"
mkdir -p "${pkgdir}/usr/"
cp -r extra/bin "${pkgdir}/usr/"
- chmod 755 "${pkgdir}/usr/"*
+ chmod 755 "${pkgdir}/usr/bin/"*
mkdir -p "${pkgdir}/usr/lib/systemd/system"
cp extra/systemd/*.service "${pkgdir}/usr/lib/systemd/system/"
mkdir -p "${pkgdir}/usr/share/doc/${pkgname}/extra"
- cp -r README.md doc "${pkgdir}/usr/share/doc/${pkgname}/"
+ cp -r README.md Changelog.md doc "${pkgdir}/usr/share/doc/${pkgname}/"
cp -r extra/examples "${pkgdir}/usr/share/doc/${pkgname}/extra/"
python extra/setup/setup.py install --root="${pkgdir}/" --optimize=1