summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--pysnip5
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9afcacc9301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pysnip-git
+ pkgdesc = PySnip is an open-source Python server implementation for the voxel-based game 'Ace of Spades'.
+ pkgver = r1752.d094fb8
+ pkgrel = 1
+ url = https://github.com/NateShoffner/pysnip
+ arch = any
+ makedepends = git
+ depends = python2-twisted
+ depends = cython2
+ depends = python2-jinja
+ depends = python2-pillow
+ depends = python2-pygeoip
+ depends = python2-crypto
+ depends = python2-pyasn1
+ provides = pysnip
+ source = pysnip-git::git://github.com/NateShoffner/pysnip.git
+ source = pysnip
+ sha256sums = SKIP
+ sha256sums = 7d4ec23421f4ab95dd5f5f563d5b7535b2840228c9abfcd4d72ca467bc42b38a
+
+pkgname = pysnip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44cd87732daf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Samuel Walladge <swalladge at gmail dot com>
+
+pkgname=pysnip-git
+_pkgname=pysnip
+pkgver=r1752.d094fb8
+pkgrel=1
+pkgdesc="PySnip is an open-source Python server implementation for the voxel-based game 'Ace of Spades'."
+arch=('any')
+url="https://github.com/NateShoffner/${_pkgname}"
+licence=('GPLv3')
+makedepends=('git')
+depends=('python2-twisted' 'cython2' 'python2-jinja' 'python2-pillow' 'python2-pygeoip' 'python2-crypto' 'python2-pyasn1')
+provides=('pysnip')
+source=("${pkgname}::git://github.com/NateShoffner/${_pkgname}.git"
+ "pysnip")
+sha256sums=('SKIP'
+ '7d4ec23421f4ab95dd5f5f563d5b7535b2840228c9abfcd4d72ca467bc42b38a')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+
+ sh build.sh
+}
+
+package() {
+
+
+ # install the custom startup script
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm755 pysnip "${pkgdir}/usr/bin"
+ chmod +x "${pkgdir}/usr/bin/pysnip"
+
+
+ cd ${pkgname}
+
+ # tidy up
+ cp feature_server/config.txt.default feature_server/config.txt
+
+ # copy in all the files
+ install -d "${pkgdir}/usr/share/pysnip"
+ cp -R {contrib,enet,examples,feature_server,py2exe,pyspades,run_server.sh} ${pkgdir}/usr/share/pysnip
+ chmod -R 755 ${pkgdir}/usr/share/pysnip
+
+}
diff --git a/pysnip b/pysnip
new file mode 100644
index 000000000000..06d91f557dca
--- /dev/null
+++ b/pysnip
@@ -0,0 +1,5 @@
+#! /usr/bin/sh
+
+cd /usr/share/pysnip
+
+sh run_server.sh "$@"