summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a8c854c4b7f..80d21f50e2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,23 @@ pkgname=python-accelerate
_name=${pkgname#python-}
pkgver=0.15.0
pkgrel=1
-pkgdesc="GTK+ frontend for Stable Diffusion"
+pkgdesc="Train and use PyTorch models with multi-GPU, TPU, mixed-precision"
arch=(any)
url="https://github.com/huggingface/$_name"
license=('MIT')
groups=()
depends=(python)
-makedepends=(python-build python-installer python-wheel)
-checkdepends=()
+makedepends=(python-build python-installer python-wheel python-setuptools)
+checkdepends=(
+ "python-pytest"
+ "python-datasets"
+ "python-evaluate"
+ "python-transformers"
+ "python-scipy"
+ "python-scikit-learn"
+ "python-deepspeed"
+ "python-tqdm"
+)
optdepends=()
provides=()
conflicts=()
@@ -31,3 +40,8 @@ package() {
cd "$_name-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
}
+
+check() {
+ cd "$_name-$pkgver"
+ pytest tests
+}