summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d811e3d05843..3ef30e76610f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-adafruit-circuitpython-framebuf
pkgdesc = CircuitPython frambuf module, based on the Python frambuf module
- pkgver = 1.4.14
+ pkgver = 1.6.0
pkgrel = 0
url = https://github.com/adafruit/Adafruit_CircuitPython_framebuf
- arch = armv6h
- arch = armv7h
+ arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python
depends = python-adafruit-blinka
- optdepends = python-raspberry-gpio
- source = https://pypi.io/packages/source/a/adafruit-circuitpython-framebuf/adafruit-circuitpython-framebuf-1.4.14.tar.gz
- sha256sums = edf9402d5456c25368c7cd5c251589a057f6db0e3ab0983f54691575a235c109
+ optdepends = python-rpi-gpio
+ source = https://pypi.io/packages/source/a/adafruit-circuitpython-framebuf/adafruit-circuitpython-framebuf-1.6.0.tar.gz
+ sha256sums = 9ad8222bc5ef91ea0bd92fd30c1eedbe540fc51e95d162b767fabe9480925f11
pkgname = python-adafruit-circuitpython-framebuf
diff --git a/PKGBUILD b/PKGBUILD
index e5ba686d9bfa..5f249041f217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,33 @@
pkgname=python-adafruit-circuitpython-framebuf
_pypi_pkgname=adafruit-circuitpython-framebuf
-pkgver=1.4.14
+pkgver=1.6.0
pkgrel=0
pkgdesc="CircuitPython frambuf module, based on the Python frambuf module"
-arch=('armv6h' 'armv7h')
+arch=('any')
url="https://github.com/adafruit/Adafruit_CircuitPython_framebuf"
license=('MIT')
-makedepends=('python-setuptools' 'python-pip')
-depends=('python' 'python-adafruit-blinka')
-optdepends=('python-raspberry-gpio')
+makedepends=(
+'python-build'
+'python-installer'
+'python-wheel'
+'python-setuptools-scm'
+)
+depends=(
+'python'
+'python-adafruit-blinka'
+)
+optdepends=('python-rpi-gpio')
source=("https://pypi.io/packages/source/a/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
-sha256sums=('edf9402d5456c25368c7cd5c251589a057f6db0e3ab0983f54691575a235c109')
+sha256sums=('9ad8222bc5ef91ea0bd92fd30c1eedbe540fc51e95d162b767fabe9480925f11')
build() {
cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py build || return 1
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py install --root=${pkgdir} --optimize=1 || return 1
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/${_pypi_pkgname}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm644 -t "$pkgdir/usr/share/license/$pkgname" LICENSE
}