summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb59c89f609f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ahkab
+ pkgdesc = A SPICE-like electronic circuit simulator written in Python
+ pkgver = 0.18
+ pkgrel = 1
+ url = https://ahkab.github.io/ahkab/
+ arch = any
+ license = GPL2
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-sympy
+ depends = python-tabulate
+ optdepends = python-matplotlib: plotting
+ source = ahkab-0.18.tar.gz::https://github.com/ahkab/ahkab/archive/v0.18.tar.gz
+ md5sums = 9f82ed50cf654e87437713a87ced4f1f
+
+pkgname = python-ahkab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a26d8c8f5fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Christoph Pohl <christophpohl@gmx.com>
+pkgname=python-ahkab
+pkgver=0.18
+pkgrel=1
+pkgdesc="A SPICE-like electronic circuit simulator written in Python"
+arch=('any')
+url="https://ahkab.github.io/ahkab/"
+license=('GPL2')
+depends=('python-numpy' 'python-scipy' 'python-sympy' 'python-tabulate')
+optdepends=('python-matplotlib: plotting')
+source=("ahkab-$pkgver.tar.gz::https://github.com/ahkab/ahkab/archive/v$pkgver.tar.gz")
+md5sums=('9f82ed50cf654e87437713a87ced4f1f')
+
+package() {
+ cd "$srcdir/ahkab-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}