summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..059f80228642
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.0
+# Mon Jan 5 15:45:53 UTC 2015
+pkgbase = python-aiodns
+ pkgdesc = An asynchronous python DNS library using asyncio
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/saghul/aiodns
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python
+ depends = python-pycares
+ source = https://github.com/saghul/aiodns/archive/aiodns-0.3.1.tar.gz
+ sha512sums = 87e021b4d6609cf694f6d856defbab2a2d485b3720e00da3b5abd9c10dd73ae5a51664f58990e01b090e51218a8b2d3207fc16f3110fc1b4460c0817544a3af3
+
+pkgname = python-aiodns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14b648c2ce37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=python-aiodns
+_pkgname=aiodns
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="An asynchronous python DNS library using asyncio"
+arch=('i686' 'x86_64')
+url="https://github.com/saghul/aiodns"
+license=('MIT')
+depends=('python' 'python-pycares')
+
+source=("https://github.com/saghul/$_pkgname/archive/$_pkgname-${pkgver}.tar.gz")
+sha512sums=('87e021b4d6609cf694f6d856defbab2a2d485b3720e00da3b5abd9c10dd73ae5a51664f58990e01b090e51218a8b2d3207fc16f3110fc1b4460c0817544a3af3')
+
+package() {
+ cd "$_pkgname-$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}