summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7f6581728b8..96a900a4f026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,14 @@
pkgbase = python-aiohttp
pkgdesc = http client/server for asyncio
pkgver = 0.22.3
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/aiohttp
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = Apache
makedepends = python-pip
depends = python>=3.5
@@ -11,8 +16,18 @@ pkgbase = python-aiohttp
depends = python-multidict
noextract = aiohttp-0.22.3-cp35-cp35m-manylinux1_i686.whl
noextract = aiohttp-0.22.3-cp35-cp35m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-0.22.3.tar.gz
- md5sums = 8c75aa7aad0c428a0dbed1380e9c0807
+ source_i686 = https://files.pythonhosted.org/packages/cp35/a/aiohttp/aiohttp-0.22.3-cp35-cp35m-manylinux1_i686.whl
+ md5sums_i686 = f50387b72362cc798e4c8a8e20ffa78c
+ source_x86_64 = https://files.pythonhosted.org/packages/cp35/a/aiohttp/aiohttp-0.22.3-cp35-cp35m-manylinux1_x86_64.whl
+ md5sums_x86_64 = b85e5c06ab167ec0d585d436d44f4e62
+ source_arm = https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-0.22.3.tar.gz
+ md5sums_arm = 8c75aa7aad0c428a0dbed1380e9c0807
+ source_armv6h = https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-0.22.3.tar.gz
+ md5sums_armv6h = 8c75aa7aad0c428a0dbed1380e9c0807
+ source_armv7h = https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-0.22.3.tar.gz
+ md5sums_armv7h = 8c75aa7aad0c428a0dbed1380e9c0807
+ source_aarch64 = https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-0.22.3.tar.gz
+ md5sums_aarch64 = 8c75aa7aad0c428a0dbed1380e9c0807
pkgname = python-aiohttp
diff --git a/PKGBUILD b/PKGBUILD
index 7c0924740a11..e2ba223fee06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,34 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
_name=aiohttp
pkgname=python-aiohttp
pkgver=0.22.3
-pkgrel=1
+pkgrel=2
pkgdesc='http client/server for asyncio'
-arch=('any')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://pypi.python.org/pypi/$_name"
license=('Apache')
depends=('python>=3.5' 'python-chardet' 'python-multidict')
makedepends=('python-pip')
+
+# binary packages
_wheelbase="$_name-$pkgver-cp35-cp35m-manylinux1"
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
source_i686=( "https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_i686.whl")
source_x86_64=("https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_x86_64.whl")
-noextract=("${_wheelbase}_"{i686,x86_64}.whl)
-md5sums=('8c75aa7aad0c428a0dbed1380e9c0807')
md5sums_i686=('f50387b72362cc798e4c8a8e20ffa78c')
md5sums_x86_64=('b85e5c06ab167ec0d585d436d44f4e62')
+noextract=("${_wheelbase}_"{i686,x86_64}.whl)
+
+# source code package
+_s="https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+source_arm=("$_s")
+source_armv6h=("$_s")
+source_armv7h=("$_s")
+source_aarch64=("$_s")
+_m=('8c75aa7aad0c428a0dbed1380e9c0807')
+md5sums_arm=("$_m")
+md5sums_armv6h=("$_m")
+md5sums_armv7h=("$_m")
+md5sums_aarch64=("$_m")
package() {
case "$CARCH" in