summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--CHANGES.rst34
-rw-r--r--PKGBUILD42
3 files changed, 69 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a954a740732..8ef8e88729b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Mar 10 16:13:15 UTC 2016
pkgbase = python-aiowsgi
- pkgdesc = A minimalist wsgi server using asyncio
- pkgver = 0.5
+ pkgdesc = Minimal wsgi server using asyncio
+ pkgver = 0.7
pkgrel = 1
- url = https://aiowsgi.readthedocs.org/
+ url = https://github.com/gawel/aiowsgi
+ changelog = CHANGES.rst
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = unzip
depends = python-webob
depends = python-waitress
- source = https://pypi.python.org/packages/source/a/aiowsgi/aiowsgi-0.5.zip
- md5sums = 644be06095f4c86035af7586c271ce9f
+ source = python-aiowsgi-0.7.tar.gz::https://files.pythonhosted.org/packages/source/a/aiowsgi/aiowsgi-0.7.tar.gz
+ sha256sums = 9fad305430fa39d54cd10a47a367a98c47424e5f176774d443bcf48aa5b5be33
pkgname = python-aiowsgi
-
diff --git a/CHANGES.rst b/CHANGES.rst
new file mode 100644
index 000000000000..82a012f5694f
--- /dev/null
+++ b/CHANGES.rst
@@ -0,0 +1,34 @@
+0.7 (2018-11-02)
+================
+
+- remove deprecated asyncio.async calls
+
+
+0.6 (2016-06-30)
+================
+
+- Small changes to work with latest waitress release (force encoding data to utf8)
+
+
+0.5 (2015-03-19)
+================
+
+- Use executor iif application is not a coroutine
+
+
+0.4 (2015-03-13)
+================
+
+- Added thread.WSGIServer
+
+
+0.3 (2014-06-19)
+================
+
+- Compat with latest trollius
+
+
+0.2 (2014-05-10)
+================
+
+- Use waitress's tasks to parse request and send response
diff --git a/PKGBUILD b/PKGBUILD
index 0b7107e50351..ae885a15c806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,40 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Maintainer: Dobroslaw Kijowski [dobo] <dobo90_at_gmail.com>
pkgname=python-aiowsgi
-_pkgname=aiowsgi
-pkgver=0.5
+pkgver=0.7
pkgrel=1
-pkgdesc='A minimalist wsgi server using asyncio'
-arch=(any)
-url=https://aiowsgi.readthedocs.org/
+pkgdesc='Minimal wsgi server using asyncio'
+arch=('any')
+url='https://github.com/gawel/aiowsgi'
license=('MIT')
-depends=(python-webob python-waitress)
-makedepends=(python-setuptools unzip)
-source=(https://pypi.python.org/packages/source/a/aiowsgi/${_pkgname}-${pkgver}.zip)
-md5sums=(644be06095f4c86035af7586c271ce9f)
+depends=('python-webob' 'python-waitress')
+makedepends=('python-setuptools')
+# checkdepends=('python-pytest-runner' 'python-webtest' 'python-wsgiproxy2')
+changelog=CHANGES.rst
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/aiowsgi/aiowsgi-$pkgver.tar.gz")
+sha256sums=('9fad305430fa39d54cd10a47a367a98c47424e5f176774d443bcf48aa5b5be33')
+
+## interfered with tests
+# prepare() {
+# cd "aiowsgi-$pkgver"
+# rm setup.cfg
+# }
build() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py build
+ cd "aiowsgi-$pkgver"
+ python setup.py build
}
+## tests fail because python-waitress made breaking changes
+# check() {
+# cd "aiowsgi-$pkgver"
+# python setup.py pytest
+# }
+
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py install --root=${pkgdir} --optimize=1
+ export PYTHONHASHSEED=0
+ cd "aiowsgi-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}