summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afc25474db5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ansi-git
+ pkgdesc = ANSI cursor movement and graphics
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/tehmaze/ansi
+ arch = any
+ license = MIT
+ depends = python
+ options = !emptydirs
+ source = git+https://github.com/tehmaze/ansi.git
+ md5sums = SKIP
+
+pkgname = python-ansi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..228c5d2b1231
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=python-ansi-git
+_pkgname=ansi
+pkgver=latest
+pkgrel=1
+pkgdesc="ANSI cursor movement and graphics"
+arch=('any')
+url="https://github.com/tehmaze/ansi"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+source=("git+https://github.com/tehmaze/ansi.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+