summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rw-r--r--fix-pydebug.patch11
3 files changed, 9 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 442ab935ba1c..a65c30c7b799 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu May 4 02:59:14 UTC 2017
pkgbase = python-apt
pkgdesc = Python binding of libapt-pkg
- pkgver = 1.4.0~beta3
+ pkgver = 1.8.4
pkgrel = 1
url = https://tracker.debian.org/pkg/python-apt
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = python-distutils-extra
makedepends = python2-distutils-extra
depends = apt>=1.4
options = !emptydirs
- source = http://ftp.debian.org/debian/pool/main/p/python-apt/python-apt_1.4.0~beta3.tar.xz
- source = fix-pydebug.patch
- sha256sums = ee5d237a3ab91292e44dc9edf593e906bd5ca67953f828c3aa19b921b42f8485
- sha256sums = 8a652b45fc4cdb27d672c355858813678908a8b6ab6a8dde8b843193eb960646
+ source = https://salsa.debian.org/apt-team/python-apt/-/archive/1.8.4/python-apt-1.8.4.tar.gz
+ sha256sums = 76dacd47431f6f34cf2c017051217daab498c6a3c87b4861052640c2eef92dd2
pkgname = python-apt
depends = apt>=1.4
diff --git a/PKGBUILD b/PKGBUILD
index f22a2db94329..2a26af69c0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
# Contributor: Jacob Alexander haata at kiibohd dot com
+# Contributor: Pellegrino Prevete pellegrinoprevete at gmail dot com
pkgname=('python-apt' 'python2-apt')
_pkgname=python-apt
_pkgname2=python2-apt
-pkgver=1.4.0~beta3
+pkgver=1.8.4
pkgrel=1
pkgdesc="Python binding of libapt-pkg"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://tracker.debian.org/pkg/python-apt"
license=('GPL2')
depends=('apt>=1.4')
makedepends=('python-distutils-extra' 'python2-distutils-extra')
conflicts=()
options=(!emptydirs)
-source=(http://ftp.debian.org/debian/pool/main/p/$_pkgname/${_pkgname}_$pkgver.tar.xz
-fix-pydebug.patch)
-sha256sums=('ee5d237a3ab91292e44dc9edf593e906bd5ca67953f828c3aa19b921b42f8485'
- '8a652b45fc4cdb27d672c355858813678908a8b6ab6a8dde8b843193eb960646')
-
-prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- patch -N -p1 < ../fix-pydebug.patch
-}
+source=(https://salsa.debian.org/apt-team/python-apt/-/archive/${pkgver}/python-apt-${pkgver}.tar.gz)
+sha256sums=('76dacd47431f6f34cf2c017051217daab498c6a3c87b4861052640c2eef92dd2')
package_python-apt() {
depends+=('python')
diff --git a/fix-pydebug.patch b/fix-pydebug.patch
deleted file mode 100644
index 43bb21b50fcb..000000000000
--- a/fix-pydebug.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- python-apt-0.8.8.1/tests/test_all.py 2013-01-29 17:19:38.706662531 +0100
-+++ python-apt-0.8.8.1_new/tests/test_all.py 2013-01-29 17:17:22.816301842 +0100
-@@ -12,7 +12,7 @@
- # workaround for py3.2 that apparently does not have this anymore
- # it has "abiflags"
- if not hasattr(sys, "pydebug"):
-- if sys.abiflags.startswith("d"):
-+ if hasattr(sys, "abiflags") and sys.abiflags.startswith("d"):
- sys.pydebug = True
- else:
- sys.pydebug = False