summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD29
-rw-r--r--fix-pydebug.patch11
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea6030817065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-apt
+ pkgdesc = Python binding of libapt-pkg
+ pkgver = 0.9.3.7
+ pkgrel = 1
+ url = http://packages.debian.org/sid/python-apt
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python-distutils-extra
+ depends = python
+ depends = apt>=1.0.4
+ options = !emptydirs
+ source = http://ftp.debian.org/debian/pool/main/p/python-apt/python-apt_0.9.3.7.tar.xz
+ source = fix-pydebug.patch
+ sha256sums = 53ae9e40de02285bde3e57b62abf20aec37bebaff3ae96880873a55efe546215
+ sha256sums = 8a652b45fc4cdb27d672c355858813678908a8b6ab6a8dde8b843193eb960646
+
+pkgname = python-apt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7bfad8ad030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=python-apt
+_python=python
+pkgver=0.9.3.7
+pkgrel=1
+pkgdesc="Python binding of libapt-pkg"
+arch=('i686' 'x86_64')
+url="http://packages.debian.org/sid/python-apt"
+license=('GPL2')
+depends=('python' 'apt>=1.0.4')
+makedepends=('python-distutils-extra')
+conflicts=()
+options=(!emptydirs)
+source=(http://ftp.debian.org/debian/pool/main/p/$pkgname/${pkgname}_$pkgver.tar.xz
+fix-pydebug.patch)
+sha256sums=('53ae9e40de02285bde3e57b62abf20aec37bebaff3ae96880873a55efe546215'
+ '8a652b45fc4cdb27d672c355858813678908a8b6ab6a8dde8b843193eb960646')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ $_python setup.py build
+ patch -N -p1 < ../fix-pydebug.patch
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ $_python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/fix-pydebug.patch b/fix-pydebug.patch
new file mode 100644
index 000000000000..43bb21b50fcb
--- /dev/null
+++ b/fix-pydebug.patch
@@ -0,0 +1,11 @@
+--- python-apt-0.8.8.1/tests/test_all.py 2013-01-29 17:19:38.706662531 +0100
++++ python-apt-0.8.8.1_new/tests/test_all.py 2013-01-29 17:17:22.816301842 +0100
+@@ -12,7 +12,7 @@
+ # workaround for py3.2 that apparently does not have this anymore
+ # it has "abiflags"
+ if not hasattr(sys, "pydebug"):
+- if sys.abiflags.startswith("d"):
++ if hasattr(sys, "abiflags") and sys.abiflags.startswith("d"):
+ sys.pydebug = True
+ else:
+ sys.pydebug = False