summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aaa02bd5ffe5..bbcc5217f093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Feb 8 19:49:02 UTC 2018
+# Sun Feb 18 16:19:30 UTC 2018
pkgbase = python-astroplan
pkgdesc = A python package to help astronomers plan observations
pkgver = 0.4
@@ -13,6 +13,8 @@ pkgbase = python-astroplan
makedepends = python-pytz
makedepends = python-astropy-helpers
makedepends = python-sphinx
+ makedepends = python-matplotlib
+ makedepends = python-astroquery
source = https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-0.4.tar.gz
source = python-astroplan.patch
md5sums = 8ac6dec44aadae0b98775658856a4f01
diff --git a/PKGBUILD b/PKGBUILD
index dac54b5a6581..60a05e1c0b5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A python package to help astronomers plan observations"
arch=('i686' 'x86_64')
url="https://astroplan.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('cython' 'python-astropy>=1.3' 'python-pytz' 'python-astropy-helpers' 'python-sphinx')
+makedepends=('cython' 'python-astropy>=1.3' 'python-pytz' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib' 'python-astroquery')
#checkdepends=('python-matplotlib' 'python-pytest-mpl')
source=("https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-${pkgver}.tar.gz"
'python-astroplan.patch')
@@ -15,7 +15,8 @@ md5sums=('8ac6dec44aadae0b98775658856a4f01'
'dbeae8fbb4ac0945676630db8d219c59')
prepare() {
- cd "${srcdir}/astroplan-${pkgver}"
+ cd ${srcdir}/astroplan-${pkgver}
+
patch -Np1 -i "${srcdir}/python-astroplan.patch"
}
@@ -28,7 +29,7 @@ build () {
}
#check(){
-# cd $srcdir/astroplan-${pkgver}
+# cd ${srcdir}/astroplan-${pkgver}
#
# python setup.py test
#}