summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD54
-rw-r--r--python-astroplan.patch (renamed from astroplan-ephem.patch)15
3 files changed, 66 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 726a82ebab4f..6e2aff320870 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Feb 3 15:45:40 UTC 2018
+# Thu Feb 8 18:20:39 UTC 2018
pkgbase = python-astroplan
pkgdesc = A python package to help astronomers plan observations
pkgver = 0.4
@@ -9,17 +9,23 @@ pkgbase = python-astroplan
arch = x86_64
license = BSD
makedepends = cython
+ makedepends = python-astropy-helpers
+ makedepends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-0.4.tar.gz
+ source = python-astroplan.patch
+ md5sums = 8ac6dec44aadae0b98775658856a4f01
+ md5sums = dbeae8fbb4ac0945676630db8d219c59
+
+pkgname = python-astroplan
depends = python>=3.5
- depends = python-numpy
+ depends = python-numpy>=1.10
depends = python-astropy>=1.3
depends = python-pytz
optdepends = python-matplotlib: Plotting support
optdepends = python-pytest-mpl: Testing the plot function
optdepends = python-astroquery: Astroquery support
- source = https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-0.4.tar.gz
- source = astroplan-ephem.patch
- md5sums = 8ac6dec44aadae0b98775658856a4f01
- md5sums = 3b992c8bd610d72ff2c61a059bb20e30
+ optdepends = python-astroplan-doc: Documentation for astroplan
-pkgname = python-astroplan
+pkgname = python-astroplan-doc
+ pkgdesc = Documentation for Python astroplan module
diff --git a/PKGBUILD b/PKGBUILD
index 6a1f4a0e0352..4bc49bf8e9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,56 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
-pkgname=python-astroplan
+pkgbase=python-astroplan
+pkgname=('python-astroplan' 'python-astroplan-doc')
pkgver=0.4
pkgrel=2
pkgdesc="A python package to help astronomers plan observations"
arch=('i686' 'x86_64')
url="https://astroplan.readthedocs.io/en/latest/"
license=('BSD')
-depends=('python>=3.5' 'python-numpy' 'python-astropy>=1.3' 'python-pytz')
-makedepends=('cython')
-optdepends=('python-matplotlib: Plotting support'
- 'python-pytest-mpl: Testing the plot function'
- 'python-astroquery: Astroquery support')
+makedepends=('cython' 'python-astropy-helpers' 'python-sphinx')
+#checkdepends=('python-matplotlib' 'python-pytest-mpl')
source=("https://files.pythonhosted.org/packages/source/a/astroplan/astroplan-${pkgver}.tar.gz"
- 'astroplan-ephem.patch')
+ 'python-astroplan.patch')
md5sums=('8ac6dec44aadae0b98775658856a4f01'
- '3b992c8bd610d72ff2c61a059bb20e30')
+ 'dbeae8fbb4ac0945676630db8d219c59')
prepare() {
cd "${srcdir}/astroplan-${pkgver}"
- patch -Np1 -i "${srcdir}/astroplan-ephem.patch"
+ patch -Np1 -i "${srcdir}/python-astroplan.patch"
}
-package() {
- cd ${srcdir}/astroplan-${pkgver}
+build () {
+ cd ${srcdir}/astroplan-${pkgver}
+ python setup.py build --use-system-libraries --offline
- install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
- install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+ msg "Building Docs"
+ python setup.py build_docs
+}
+
+#check(){
+# cd $srcdir/astroplan-${pkgver}
+#
+# python setup.py test
+#}
+
+package_python-astroplan() {
+ depends=('python>=3.5' 'python-numpy>=1.10' 'python-astropy>=1.3' 'python-pytz')
+ optdepends=('python-matplotlib: Plotting support'
+ 'python-pytest-mpl: Testing the plot function'
+ 'python-astroquery: Astroquery support'
+ 'python-astroplan-doc: Documentation for astroplan')
+ cd ${srcdir}/astroplan-${pkgver}
+
+ install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+}
+
+package_python-astroplan-doc() {
+ pkgdesc="Documentation for Python astroplan module"
+ cd ${srcdir}/astroplan-${pkgver}/build/sphinx
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
}
diff --git a/astroplan-ephem.patch b/python-astroplan.patch
index b71ec9ae1716..ef204b1d6f73 100644
--- a/astroplan-ephem.patch
+++ b/python-astroplan.patch
@@ -1,5 +1,5 @@
---- a/astroplan/conftest.py 2017-10-24 09:42:38.000000000 +0800
-+++ b/astroplan/conftest.py 2018-02-03 17:18:18.183223264 +0800
+--- a/astroplan/conftest.py 2018-02-08 20:25:42.248064331 +0800
++++ b/astroplan/conftest.py 2018-02-08 20:22:39.068329472 +0800
@@ -40,7 +40,7 @@
try:
PYTEST_HEADER_MODULES['Astropy'] = 'astropy'
@@ -9,3 +9,14 @@
PYTEST_HEADER_MODULES['matplotlib'] = 'matplotlib'
PYTEST_HEADER_MODULES['nose'] = 'nose'
PYTEST_HEADER_MODULES['pytest-mpl'] = 'pytest_mpl'
+--- a/setup.cfg 2017-10-24 09:42:38.000000000 +0800
++++ b/setup.cfg 2018-02-08 20:24:32.376333521 +0800
+@@ -13,7 +13,7 @@
+ doctest_plus = enabled
+
+ [ah_bootstrap]
+-auto_use = True
++auto_use = False
+
+ [metadata]
+ package_name = astroplan