summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6aee69edc92f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 10 17:17:35 UTC 2018
+pkgbase = python-astropy-doc
+ pkgdesc = Documentation for AstroPy
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = http://www.astropy.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-yaml
+ makedepends = python-astropy
+ makedepends = python-astropy-helpers
+ makedepends = python-scikit-image
+ makedepends = python-sphinx-gallery
+ source = https://files.pythonhosted.org/packages/source/a/astropy/astropy-2.0.4.tar.gz
+ md5sums = 5fddc8d2d11ec0496c7c8f808b656a7d
+
+pkgname = python-astropy-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b4b053fd75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-astropy-doc
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="Documentation for AstroPy"
+arch=('i686' 'x86_64')
+url="http://www.astropy.org"
+license=('BSD')
+makedepends=('python-yaml' 'python-astropy' 'python-astropy-helpers' 'python-scikit-image' 'python-sphinx-gallery')
+source=("https://files.pythonhosted.org/packages/source/a/astropy/astropy-${pkgver}.tar.gz")
+md5sums=('5fddc8d2d11ec0496c7c8f808b656a7d')
+
+prepare() {
+ cd ${srcdir}/astropy-${pkgver}
+ sed -i -e '/auto_use/s/True/False/' setup.cfg
+}
+
+build() {
+ cd ${srcdir}/astropy-${pkgver}/docs
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/astropy-${pkgver}/docs/_build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/python-astropy"
+ cp -a html "${pkgdir}/usr/share/doc/python-astropy"
+}