summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index babd5d47df62..4e0c04ec912f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-astropy-healpix
pkgdesc = BSD-licensed HEALPix for Astropy
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = http://astropy-healpix.readthedocs.io
arch = i686
arch = x86_64
- license = BSD
- checkdepends = python-pytest-doctestplus
+ license = BSD-3-Clause
checkdepends = python-pytest-astropy-header
+ checkdepends = python-pytest-doctestplus
checkdepends = python-hypothesis
checkdepends = python-healpy
makedepends = python-setuptools-scm
@@ -18,11 +18,11 @@ pkgbase = python-astropy-healpix
makedepends = python-numpy
makedepends = python-sphinx-astropy
makedepends = python-astropy
- source = https://files.pythonhosted.org/packages/source/a/astropy_healpix/astropy_healpix-1.0.2.tar.gz
+ source = https://files.pythonhosted.org/packages/source/a/astropy_healpix/astropy_healpix-1.0.3.tar.gz
source = https://lambda.gsfc.nasa.gov/data/map/dr3/skymaps/5yr//wmap_band_imap_r9_5yr_K_v3.fits
source = fix_deprecation_warning.patch
source = use_local_doc_fits.patch
- md5sums = 2ffe869d662a8ccdd9a5229fcffb2dda
+ md5sums = 6e791154dfc2510353cfd3e44e7e783d
md5sums = f183da2392e37b9b424e9866d7bca559
md5sums = 71e532a1fed7a57d4ccf0d3e41035dd8
md5sums = 6fc85696c0103b265309db0fa3339b33
diff --git a/PKGBUILD b/PKGBUILD
index 44d9c812913c..8520a35151d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgbase=python-astropy-healpix
_pyname=astropy_healpix
_pname=${pkgbase#python-}
pkgname=("python-${_pname}" "python-${_pname}-doc")
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="BSD-licensed HEALPix for Astropy"
arch=('i686' 'x86_64')
url="http://astropy-healpix.readthedocs.io"
-license=('BSD')
+license=('BSD-3-Clause')
makedepends=('python-setuptools-scm'
'python-extension-helpers'
'python-wheel'
@@ -17,15 +17,15 @@ makedepends=('python-setuptools-scm'
'python-numpy'
'python-sphinx-astropy'
'python-astropy')
-checkdepends=('python-pytest-doctestplus'
- 'python-pytest-astropy-header'
+checkdepends=('python-pytest-astropy-header'
+ 'python-pytest-doctestplus'
'python-hypothesis'
'python-healpy') # astropy already in makedepends
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"https://lambda.gsfc.nasa.gov/data/map/dr3/skymaps/5yr//wmap_band_imap_r9_5yr_K_v3.fits"
'fix_deprecation_warning.patch'
'use_local_doc_fits.patch')
-md5sums=('2ffe869d662a8ccdd9a5229fcffb2dda'
+md5sums=('6e791154dfc2510353cfd3e44e7e783d'
'f183da2392e37b9b424e9866d7bca559'
'71e532a1fed7a57d4ccf0d3e41035dd8'
'6fc85696c0103b265309db0fa3339b33')
@@ -44,7 +44,7 @@ prepare() {
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation --skip-dependency-check
msg "Building Docs"
PYTHONPATH="../build/lib.linux-${CARCH}-cpython-$(get_pyver)" make -C docs html