summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 54 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3c282f561bb..a75d97747b77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
# Generated by mksrcinfo v8
-# Fri Feb 2 07:42:32 UTC 2018
+# Thu Feb 8 18:32:24 UTC 2018
pkgbase = python-astropy-healpix
pkgdesc = BSD-licensed HEALPix for Astropy
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = http://astropy-healpix.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = BSD
makedepends = cython
- depends = python
+ makedepends = python-astropy-helpers
+ makedepends = python-sphinx
+ source = https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-0.2.tar.gz
+ md5sums = 88cbb91e9c4dc61740735c9a9bdaaec5
+
+pkgname = python-astropy-healpix
+ depends = python>=3.5
depends = python-numpy>=1.10
depends = python-astropy>=1.2
optdepends = python-pytest: For testing
optdepends = python-healpy: For testing (will be skipped if healpy is not installed while testing)
optdepends = python-hypothesis: For the healpy-related tests
- source = https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-0.2.tar.gz
- md5sums = 88cbb91e9c4dc61740735c9a9bdaaec5
+ optdepends = python-astropy-healpix-doc: Documentation for Astropy-HEALPix
-pkgname = python-astropy-healpix
+pkgname = python-astropy-healpix-doc
+ pkgdesc = Documentation for AstroPy-HEALPix
diff --git a/PKGBUILD b/PKGBUILD
index be37048b780c..02e45fb02787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,53 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
-pkgname=python-astropy-healpix
+pkgbase=python-astropy-healpix
+pkgname=('python-astropy-healpix' 'python-astropy-healpix-doc')
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="BSD-licensed HEALPix for Astropy"
arch=('i686' 'x86_64')
url="http://astropy-healpix.readthedocs.io/en/latest/"
license=('BSD')
-depends=('python' 'python-numpy>=1.10' 'python-astropy>=1.2')
-makedepends=('cython')
-optdepends=('python-pytest: For testing'
- 'python-healpy: For testing (will be skipped if healpy is not installed while testing)'
- 'python-hypothesis: For the healpy-related tests')
+makedepends=('cython' 'python-astropy-helpers' 'python-sphinx')
+#checkdepends=('python-pytest' 'python-healpy' 'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-${pkgver}.tar.gz")
md5sums=('88cbb91e9c4dc61740735c9a9bdaaec5')
-package() {
- cd ${srcdir}/astropy-healpix-${pkgver}
+prepare() {
+ cd ${srcdir}/astropy-healpix-${pkgver}
+ sed -i -e '/auto_use/s/True/False/' setup.cfg
+}
+
+build() {
+ cd ${srcdir}/astropy-healpix-${pkgver}
+ python setup.py build --use-system-libraries --offline
+
+ msg "Building Docs"
+ python setup.py build_docs
+}
+
+#check(){
+# cd $srcdir/astropy-healpix-${pkgver}
+#
+# python setup.py test
+#}
+
+package_python-astropy-healpix() {
+ depends=('python>=3.5' 'python-numpy>=1.10' 'python-astropy>=1.2')
+ optdepends=('python-pytest: For testing'
+ 'python-healpy: For testing (will be skipped if healpy is not installed while testing)'
+ 'python-hypothesis: For the healpy-related tests'
+ 'python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
+ cd ${srcdir}/astropy-healpix-${pkgver}
+
+ install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+}
+
+package_python-astropy-healpix-doc() {
+ pkgdesc="Documentation for AstroPy-HEALPix"
+ cd ${srcdir}/astropy-healpix-${pkgver}/docs/_build
- install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
}