summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c373549356..82be9a1b956b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,14 @@ pkgbase = python-astropy-healpix
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python2-pytest32
+ checkdepends = python2-healpy
+ checkdepends = python2-hypothesis
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = python2-numpy
makedepends = python-astropy
- makedepends = python-astropy-helpers>=3.1
- makedepends = python-astropy-helpers<3.2
+ makedepends = python-astropy-helpers31
makedepends = python2-astropy-helpers
makedepends = python-sphinx-astropy
source = https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-0.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c60601d9a1d5..aa46e0cde41d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ pkgdesc="BSD-licensed HEALPix for Astropy"
arch=('i686' 'x86_64')
url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python-astropy-helpers<3.2' 'python2-astropy-helpers' 'python-sphinx-astropy')
-#checkdepends=('python-pytest-astropy'
-# 'python2-pytest32'
-# 'python2-healpy'
-# 'python-healpy'
-# 'python2-hypothesis'
-# 'python-hypothesis')
+makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers31' 'python2-astropy-helpers' 'python-sphinx-astropy')
+checkdepends=('python2-pytest32'
+# 'python-pytest-astropy'
+ 'python2-healpy'
+# 'python-healpy'
+# 'python-hypothesis'
+ 'python2-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"python2-${_pyname}.install"
'fix_deprecation_warning.patch')
@@ -43,17 +43,17 @@ build() {
python setup.py build_docs
}
-#check() {
-# msg "Checking Python3"
-# cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
-#
-# if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
-# msg "Checking Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
-# fi
-#}
+check() {
+# msg "Checking Python3"
+# cd ${srcdir}/${_pyname}-${pkgver}
+# python setup.py test
+
+ if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
+# msg "Checking Python2"
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+ python2 setup.py test
+ fi
+}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')