summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
-rw-r--r--python2-astropy-healpix.install5
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 365f0667e892..58ff92ef54bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Feb 23 11:44:25 UTC 2019
+# Mon Feb 25 02:50:22 UTC 2019
pkgbase = python-astropy-healpix
pkgdesc = BSD-licensed HEALPix for Astropy
pkgver = 0.4
@@ -9,10 +9,7 @@ pkgbase = python-astropy-healpix
arch = x86_64
license = BSD
checkdepends = python-pytest-astropy
- checkdepends = python2-pytest32
- checkdepends = python2-healpy
checkdepends = python-healpy
- checkdepends = python2-hypothesis
checkdepends = python-hypothesis
makedepends = python-setuptools
makedepends = python2-setuptools
@@ -23,8 +20,10 @@ pkgbase = python-astropy-healpix
makedepends = python-sphinx-astropy
source = https://files.pythonhosted.org/packages/source/a/astropy-healpix/astropy-healpix-0.4.tar.gz
source = fix_deprecation_warning.patch
+ source = python2-astropy-healpix.install
md5sums = 59174f71ae6ef8b8969b2cfce702231e
md5sums = 71e532a1fed7a57d4ccf0d3e41035dd8
+ md5sums = 68d099a7f241f405c488da6f09618890
pkgname = python-astropy-healpix
depends = python>=3.5
@@ -33,10 +32,14 @@ pkgname = python-astropy-healpix
optdepends = python-astropy-healpix-doc: Documentation for Astropy-HEALPix
pkgname = python2-astropy-healpix
+ install = python2-astropy-healpix.install
depends = python2>=2.7
depends = python2-numpy>=1.10
depends = python2-astropy>=1.2
optdepends = python-astropy-healpix-doc: Documentation for Astropy-HEALPix
+ optdepends = python2-pytest32: For testing
+ optdepends = python2-hypothesis: For testing
+ optdepends = python2-healpy: For testing
pkgname = python-astropy-healpix-doc
pkgdesc = Documentation for AstroPy-HEALPix
diff --git a/PKGBUILD b/PKGBUILD
index 2e9e9c6d9411..65fa705af221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,17 @@ url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy'
- 'python2-pytest32'
- 'python2-healpy'
+# 'python2-pytest32'
+# 'python2-healpy'
'python-healpy'
- 'python2-hypothesis'
+# 'python2-hypothesis'
'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- 'fix_deprecation_warning.patch')
+ 'fix_deprecation_warning.patch'
+ 'python2-astropy-healpix.install')
md5sums=('59174f71ae6ef8b8969b2cfce702231e'
- '71e532a1fed7a57d4ccf0d3e41035dd8')
+ '71e532a1fed7a57d4ccf0d3e41035dd8'
+ '68d099a7f241f405c488da6f09618890')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -42,18 +44,22 @@ build() {
}
check() {
- msg "Checking Python3"
+# msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py test
- msg "Checking Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
+# msg "Checking Python2"
+# cd ${srcdir}/${_pyname}-${pkgver}-py2
+# python2 setup.py test
}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
+ 'python2-pytest32: For testing'
+ 'python2-hypothesis: For testing'
+ 'python2-healpy: For testing')
+ install=python2-astropy-healpix.install
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/python2-astropy-healpix.install b/python2-astropy-healpix.install
new file mode 100644
index 000000000000..f4ad517d6897
--- /dev/null
+++ b/python2-astropy-healpix.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "
+ ==> If you want to run the testing for python2 version of astropy-healpix, you need to remove the python2-pytest-cov package first.
+ "
+}