summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80fcd1a46123
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-asyncore-wsgi
+ pkgdesc = Asynchronous WSGI and WebSocket server based on asyncore module.
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://github.com/romanvm/asyncore-wsgi
+ arch = any
+ license = MIT
+ depends = python
+ noextract = asyncore_wsgi-0.0.9-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/a/asyncore-wsgi/asyncore_wsgi-0.0.9-py2.py3-none-any.whl
+ sha256sums = de043ee1544ae1a2602ef6f8cde41b7bd9f9b29d459e1c1514fa1c655aa7c841
+
+pkgname = python-asyncore-wsgi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9731419a6e92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdb93f848588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=asyncore-wsgi
+pkgname=python-$_name
+pkgver=0.0.9
+pkgrel=1
+pkgdesc='Asynchronous WSGI and WebSocket server based on asyncore module.'
+arch=(any)
+url="https://github.com/romanvm/$_name"
+license=(MIT)
+depends=(python)
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('de043ee1544ae1a2602ef6f8cde41b7bd9f9b29d459e1c1514fa1c655aa7c841')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}