summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2dece7bb89a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-attrdict
+ pkgdesc = Push Notifications that work with just about every platform
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/bcj/attrdict
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/bcj/attrdict/archive/v2.0.0.tar.gz
+ sha256sums = e779bdb2824498311fd82068ff62c1ac01c2049a5766230f7ead2a80f4d81ed7
+
+pkgname = python-attrdict
+
+pkgname = python2-attrdict
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97484cf0bb87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.xz
+/*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1537e17cd161
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+pkgbase=python-attrdict
+pkgname=('python-attrdict' 'python2-attrdict')
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Push Notifications that work with just about every platform"
+arch=('any')
+url="https://github.com/bcj/attrdict"
+license=('GPL3')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/bcj/attrdict/archive/v$pkgver.tar.gz")
+sha256sums=('e779bdb2824498311fd82068ff62c1ac01c2049a5766230f7ead2a80f4d81ed7')
+
+prepare() {
+ cp -a AttrDict-$pkgver{,-py2}
+}
+
+build() {
+ cd "${srcdir}"/AttrDict-${pkgver}
+ python setup.py build
+
+ cd "${srcdir}"/AttrDict-${pkgver}-py2
+ python2 setup.py build
+}
+
+package_python-attrdict() {
+ cd AttrDict-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-attrdict() {
+ cd AttrDict-${pkgver}-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}