summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af92549bd1ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-autoflake
+ pkgdesc = Removes unused imports and unused variables
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/myint/autoflake
+ arch = any
+ license = Expat
+ license = License
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-autoflake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dd972eadf96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# PKGBUILD generated by pipman
+# Python package author: Steven Myint <UNKNOWN>
+pkgname=python-autoflake
+pkgver=1.2
+pkgrel=1
+pkgdesc="Removes unused imports and unused variables"
+arch=(any)
+url="https://github.com/myint/autoflake"
+license=(Expat License)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="autoflake" autoflake
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.7/site-packages/
+ cp -r $srcdir/autoflake/* $pkgdir/usr/lib/python3.7/site-packages/
+} \ No newline at end of file