summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--01-build-with-ffmpeg4.4.patch15
-rw-r--r--PKGBUILD8
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 512848698725..cc669d7ace44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-av
pkgdesc = Pythonic bindings for FFmpeg
- pkgver = 8.1.0
- pkgrel = 2
+ pkgver = 9.0.0
+ pkgrel = 1
url = https://docs.mikeboers.com/pyav/
arch = x86_64
arch = i686
@@ -12,9 +12,9 @@ pkgbase = python-av
makedepends = pkgconf
depends = python
depends = ffmpeg4.4
- source = https://files.pythonhosted.org/packages/source/a/av/av-8.1.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/a/av/av-9.0.0.tar.gz
source = 01-build-with-ffmpeg4.4.patch
- sha256sums = 0402169bc27e38e0f44e0e0e1854cf488337e86206b6d25d6dae2bfd7a1a0230
- sha256sums = c2a3ac73c69e383b956ea14da023531f9a44e281725efc97e448f29da6ad6f3a
+ sha256sums = 785b7434542e24dff32e6d78764ccd998bb1c85a48a602a2b5c8ee0d7676fbd8
+ sha256sums = 46f75e0b9c22409d0935063aca5a7b6d8f22559abcd0691d783e351862f11c25
pkgname = python-av
diff --git a/01-build-with-ffmpeg4.4.patch b/01-build-with-ffmpeg4.4.patch
index 7ae729d2addc..fed87509f232 100644
--- a/01-build-with-ffmpeg4.4.patch
+++ b/01-build-with-ffmpeg4.4.patch
@@ -1,21 +1,20 @@
diff --unified --recursive --text a/setup.py b/setup.py
---- a/setup.py 2021-12-29 20:36:22.000000000 +0200
-+++ b/setup.py 2022-02-21 16:10:47.404733470 +0200
-@@ -140,6 +140,10 @@
+--- a/setup.py 2022-03-08 01:52:23.000000000 +0200
++++ b/setup.py 2022-03-08 09:59:04.574755359 +0200
+@@ -123,6 +123,9 @@
ffmpeg_lib = []
ffmpeg_include = []
+# force ffmpeg4.4 paths
+ffmpeg_lib = ["/usr/lib/ffmpeg4.4"]
+ffmpeg_include = ["/usr/include/ffmpeg4.4"]
-+
# The "extras" to be supplied to every one of our modules.
# This is expanded heavily by the `config` command.
-@@ -412,6 +416,7 @@
- if any(s.endswith('.pyx') for s in ext.sources):
- if is_msvc():
- ext.define_macros.append(('inline', '__inline'))
+@@ -253,6 +256,7 @@
+ # the existing extension instead of replacing them all.
+ for i, ext in enumerate(self.distribution.ext_modules):
+ if any(s.endswith(".pyx") for s in ext.sources):
+ ext.library_dirs = ["/usr/lib/ffmpeg4.4"]
new_ext = cythonize(
ext,
diff --git a/PKGBUILD b/PKGBUILD
index cd39106aff1f..8dafd2ab1751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ _name=${pkgname#python-}
pkgdesc="Pythonic bindings for FFmpeg"
url="https://docs.mikeboers.com/pyav/"
-pkgver=8.1.0
-pkgrel=2
+pkgver=9.0.0
+pkgrel=1
arch=("x86_64" "i686")
license=("BSD")
@@ -27,8 +27,8 @@ source=(
"01-build-with-ffmpeg4.4.patch"
)
sha256sums=(
- "0402169bc27e38e0f44e0e0e1854cf488337e86206b6d25d6dae2bfd7a1a0230"
- "c2a3ac73c69e383b956ea14da023531f9a44e281725efc97e448f29da6ad6f3a"
+ "785b7434542e24dff32e6d78764ccd998bb1c85a48a602a2b5c8ee0d7676fbd8"
+ "46f75e0b9c22409d0935063aca5a7b6d8f22559abcd0691d783e351862f11c25"
)
prepare() {