summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f04e5456d17..0780e33c18e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,10 @@ pkgbase = python-awkward-array
url = https://github.com/scikit-hep/awkward-array
arch = any
license = BSD
+ makedepends = python2-setuptools
+ makedepends = python2-numpy
+ makedepends = python-setuptools
+ makedepends = python-numpy
options = !emptydirs
source = https://github.com/scikit-hep/awkward-array/archive/0.0.9.zip
sha256sums = a8df2fd1ffaae6baac1b322a7d3891434a11aa394cf8837ced786932eda1e45f
diff --git a/PKGBUILD b/PKGBUILD
index 020a20b3d1dd..f45ac59c6c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,8 @@ pkgver=0.0.9
pkgrel=1
pkgdesc="Manipulate jagged, chunky, and/or bitmasked arrays as easily as Numpy"
arch=('any')
+makedepends=('python2-setuptools' 'python2-numpy'
+ 'python-setuptools' 'python-numpy')
url="https://github.com/scikit-hep/awkward-array"
license=('BSD')
options=(!emptydirs)
@@ -27,22 +29,16 @@ prepare() {
-i '{}' \; -print
}
-build_python2-awkward-array() {
- makedepends=('python2-setuptools' 'python2-numpy')
+build() {
+ msg2 "Building Python3"
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python setup.py build
msg2 "Building Python2"
cd "${srcdir}/${_pkgbase}-py2-${pkgver}"
python2 setup.py build
}
-build_python-awkward-array() {
- makedepends=('python-setuptools' 'python-numpy')
-
- msg2 "Building Python3"
- cd "${srcdir}/${_pkgbase}-${pkgver}"
- python setup.py build
-}
-
package_python2-awkward-array() {
depends=('python2-numpy')
optdepends=('python2-arrow: interoperability with other applications and fast Parquet reading/writing'