summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9349220415ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-azure-cli-acs
+ pkgdesc = Microsoft Azure Command-Line Tools ACS Command Module
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-cli-core
+ depends = python-azure
+ depends = python-scp
+ depends = python-sshtunnel
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-acs/azure-cli-acs-2.0.1.tar.gz
+ md5sums = 5376d7d42e390bd267050b2339cf859d
+
+pkgname = python-azure-cli-acs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fddf645ba071
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-acs
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools ACS Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core' 'python-azure' 'python-scp' 'python-sshtunnel')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('5376d7d42e390bd267050b2339cf859d')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file