summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e40a0c2c692
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-azure-cli-documentdb
+ pkgdesc = Microsoft Azure Command-Line Tools DocumentDB Command Module
+ pkgver = 0.1.1b2
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure
+ depends = python-azure-cli-core
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-documentdb/azure-cli-documentdb-0.1.1b2.tar.gz
+ md5sums = 51e9aa265bc644a07c5a985271d41323
+
+pkgname = python-azure-cli-documentdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..881f966e2611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-documentdb
+pkgname=python-$_name
+pkgver=0.1.1b2
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools DocumentDB Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure' 'python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('51e9aa265bc644a07c5a985271d41323')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}