summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
3 files changed, 49 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6f96fba799a1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = python-balanceboard-git
+ pkgdesc = Python bindings for the Wii Balance Board
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-balanceboard
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = python>=3.0
+ depends = cython
+ depends = wiic-svn
+ source = git+https://github.com/lubosz/python-balanceboard.git
+
+pkgname = python-balanceboard-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba7dfd678413
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-balanceboard-git
+ pkgdesc = Python bindings for the Wii Balance Board
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-balanceboard
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = python>=3.0
+ depends = cython
+ depends = wiic-svn
+ source = git+https://github.com/lubosz/python-balanceboard.git
+ md5sums = SKIP
+
+pkgname = python-balanceboard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af440014da17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+_realname=python-balanceboard
+pkgname=$_realname-git
+pkgver=1
+pkgrel=1
+pkgdesc="Python bindings for the Wii Balance Board"
+arch=('i686' 'x86_64')
+url="https://github.com/lubosz/python-balanceboard"
+license=('GPLv3')
+depends=('python>=3.0' 'cython' 'wiic-svn')
+source=("git+https://github.com/lubosz/$_realname.git")
+md5sums=('SKIP')
+
+package() {
+ cd $_realname
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}