summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dadf307dad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-bitcointx
+ pkgdesc = An easy interface to the bitcoin transaction data structures
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/petertodd/python-bitcoinlib
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ options = !emptydirs
+ source = python-bitcointx-v1.1.1.tar.gz::https://github.com/Simplexum/python-bitcointx/archive/python-bitcointx-v1.1.1.tar.gz
+ sha256sums = 35edd694473517508367338888633954eaa91b2622b3caada8fd3030ddcacba2
+
+pkgname = python-bitcointx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1156cdae5721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: David Parrish
+# Contributor: David Parrish <daveparrish@tutanota.com>
+
+pkgname=python-bitcointx
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="An easy interface to the bitcoin transaction data structures"
+arch=('any')
+depends=()
+makedepends=('python-setuptools')
+url="https://github.com/petertodd/python-bitcoinlib"
+license=('LGPL3')
+options=(!emptydirs)
+source=("$pkgname-v$pkgver.tar.gz"::"https://github.com/Simplexum/python-bitcointx/archive/python-bitcointx-v${pkgver}.tar.gz")
+sha256sums=('35edd694473517508367338888633954eaa91b2622b3caada8fd3030ddcacba2')
+
+build() {
+ ls -alh && pwd
+ cd "$srcdir/$pkgname-$pkgname-v$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgname-v$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}