summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..683af153da15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-bitstring
+ pkgdesc = Python module designed to help make the creation, manipulation and analysis of binary data as simple and natural as possible
+ pkgver = 3.1.3
+ pkgrel = 1
+ url = http://code.google.com/p/python-bitstring/
+ arch = any
+ license = MIT
+ makedepends = unzip
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/b/bitstring/bitstring-3.1.3.zip
+ md5sums = 1db5d54ee269f6b54d50c3eb257eea4b
+
+pkgname = python-bitstring
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26af6a6ee2a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Thomas Conneely <tc116 at le dot ac dot uk>
+
+pkgname=python-bitstring
+pkgver=3.1.3
+pkgrel=1
+pkgdesc='Python module designed to help make the creation, manipulation and analysis of binary data as simple and natural as possible'
+arch=('any')
+url="http://code.google.com/p/python-bitstring/"
+license=('MIT')
+depends=('python')
+makedepends=('unzip')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/b/bitstring/bitstring-$pkgver.zip)
+md5sums=('1db5d54ee269f6b54d50c3eb257eea4b')
+
+build() {
+ cd ${srcdir}/bitstring-${pkgver}
+
+ #get the license file
+ python -c "import bitstring; print(bitstring.__licence__)" >> ${srcdir}/LICENSE
+}
+
+package() {
+ cd ${srcdir}/bitstring-${pkgver}
+
+ # build
+ python setup.py install --root=${pkgdir}/ --optimize=1
+
+ #install license
+ install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: